struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton" <niall.pember...@gmail.com>
Subject Re: [POLL] Drop strutsel package from 1.4?
Date Fri, 06 Jun 2008 15:31:24 GMT
On Fri, Jun 6, 2008 at 1:39 PM, Paul Benedict <pbenedict@apache.org> wrote:
> Struts 1.4 requires JDK 1.4 minimum. It's been 8 years since Struts
> inception. Would it be reasonable to allow this package to no longer be
> included in the next release? My vote is +1 because of the double
> maintenance of the taglibraries. Unlike the nested tags, strutsel does not
> offer additional functionality -- no new attributes or behavior. It just
> allows parsing for non-el containers. I think the time has come to let it
> go.

I guess I'm just wondering what harm does it do leaving it in the
release and the benefit is that it allows people with legacy apps
dependant on it to upgrade with no pain.

I'm also against the idea of moving it to a Sandbox - this is released
code, no some experimental work. If it does get dropped, then just
remove the module from the pom and leave it where it is, is the best
option IMO.

Niall

> Please let me hear your opinion.
>
> Paul

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message