struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Cooper" <mart...@apache.org>
Subject Re: Building from scratch
Date Sun, 22 Jun 2008 17:39:53 GMT
On Sun, Jun 22, 2008 at 9:51 AM, Dave Newton <newton.dave@yahoo.com> wrote:

> --- On Sun, 6/22/08, Martin Cooper <martinc@apache.org> wrote:
> > So far, nothing I've found on cwiki works. Even
> > trying to build the xwork profile complains that
> > XWork can't be found. WTF is that?
>
> Confusing, especially for those of us that aren't comfortable with Maven.


I used to be fairly comfortable with it, but I haven't done any Java
development for a while now, so it's pretty much all fallen out the other
side of my head...

The "Building with Maven" section on this page:

http://cwiki.apache.org/confluence/display/WW/Building+the+Framework+from+Source

purports to illustrate how to build S2 starting from downloading Maven for
the first time. If it was really that simple, that would be awesome, but
those instructions just don't work.

I remember enough about Maven to suspect that I need a settings.xml file,
which I don't have right now. Unfortunately, searching for "settings.xml" on
the wiki turns up exactly zero hits, so I don't have any idea what might be
needed to make things work.

The thing that really bugs me, though, is that there are persistent comments
around here about how we need more people to help with Struts, yet we don't
even have a documented way to build the damn thing that actually works. Not
much wonder we don't have more helpers!

--
Martin Cooper



> OTOH, I'm a bit more comfortable now :p
>
> If I knew more about Maven I'd document the steps I took (more or less what
> I've been posting to -user and -dev) but it's far from clear that what I did
> is even remotely reasonable (although it did, eventually, work :/ Nor do I
> know *why* it eventually worked.
>
> When the appropriate XWork (etc. I suppose, but it's only been XWork and
> the recent struts-annotations that have been an issue) has been in the Maven
> repos I've never had a problem, though; I've gone through the process on
> three clean machines, including a Mac.
>
> Dave
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message