struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Petrelli" <antonio.petre...@gmail.com>
Subject Re: [S1] Heads up: Incompatible change in Struts 1.3.6 (WAS: Re: 2.1 build - Possible problem)
Date Sun, 13 Apr 2008 17:02:37 GMT
2008/4/13, Niall Pemberton <niall.pemberton@gmail.com>:
> On Thu, Apr 10, 2008 at 9:23 AM, Antonio Petrelli
>  <antonio.petrelli@gmail.com> wrote:
>  > Hi all,
>  >  It seems that Al Sutton found an incompatible change in Struts 1.3. The
>  >  following issue added an incompatible change to Struts 1.3:
>  >  https://issues.apache.org/struts/browse/STR-2864
>  >
>  >  This leads to a compilation error for S2/S1 plugin:
>  >  https://issues.apache.org/struts/browse/WW-2586
>  >
>  >  In the "ModuleConfig" interface has been introduced the "findActionConfigId"
>  >  method. Extending classes, like:
>  >  http://svn.apache.org/repos/asf/struts/struts2/trunk/plugins/struts1/src/main/java/org/apache/struts2/s1/WrapperModuleConfig.java
>  >  cannot be built over a generic Struts 1.3.x version.
>
>
> Why not, just need to add that method to the WrapperModuleConfig - it
>  should only be called if a Struts 1.3.6 or later is used.

Well, it is exactly the opposite: only Struts 1.3.6 or later calls that method.
Anyway, implementing it does not harm anything, you are right Niall.
Well, never mind :-)

Thanks
Antonio

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message