struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Al Sutton" <al.sut...@alsutton.com>
Subject Re: 2.1 build - Possible problem
Date Thu, 10 Apr 2008 08:06:46 GMT
So would this mean that the S1 plugin for S2.1.1 wont work if the developer 
uses the S1.3.8 libraries instead of the S1.3.5 the plugin is being compiled 
with?

If so I think we may have a show stopper because we're essentially stopping 
webapp developers using the latest S1 version with S2.1.1 :(.

Al.

----- Original Message ----- 
From: "Antonio Petrelli" <antonio.petrelli@gmail.com>
To: "Struts Developers List" <dev@struts.apache.org>
Sent: Thursday, April 10, 2008 7:53 AM
Subject: Re: 2.1 build - Possible problem


> 2008/4/10, Al Sutton <al.sutton@alsutton.com>:
>>
>> D:\Struts2\Build\struts2\plugins\struts1\src\main\java\org\apache\struts2\s1\WrapperModuleConfig.java:[41,0]
>> org.apache.struts2.s1.WrapperModuleConfig is not abstract and does not
>> override abstract method findActionConfigId(java.lang.String) in
>> org.apache.struts.config.ModuleConfig
>
>
>
> AFAIK, findActionConfigId has been introduced since S1.3.6
> http://struts.apache.org/1.x/apidocs/org/apache/struts/config/ModuleConfig.html#findActionConfigId(java.lang.String)
>
> Antonio
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message