struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Pontarelli <br...@pontarelli.com>
Subject Re: API Compatibility
Date Fri, 22 Feb 2008 15:05:25 GMT
Al Sutton wrote:
> Antonio,
>
> I see where you're coming from, but I really don't think the leap from 
> S2.0 to the current S2.1 is anywhere near the leap from S1 to S2, 
> hence why I'm in favour of the 2.1 because I feel it reflects that 
> although there are some changes, many of the core concepts are the 
> same and, in many cases, changes will be limited to small sections of 
> the app (such as config files an updates to specific API usage), as 
> opposed to major changes to tag names, functionality, and design 
> concepts.
I think these are good points. The key isn't to never break things, but 
to structure it well. That is why I'd like to break everything, clean it 
all up and then move forward from something like 3.0 as the API freeze 
for all release up to 4.0. That's really what I'm after. Then I can tell 
the tools to check compatibility at the major number.

-bp

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message