struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Cooper" <mart...@apache.org>
Subject Re: First commit is a FAILURE!
Date Sat, 09 Feb 2008 22:40:47 GMT
On Feb 9, 2008 2:17 PM, Wes Wannemacher <wesw@wantii.com> wrote:

> I tried to commit a fix for WW-2477, which would be my first. I didn't
> realize that Bamboo is running/building with java 6. Shortly after
> committing, the Bamboo builds failed on the unit test I committed with
> the fix. I apologize for that :(
>
> I went ahead and deleted the test (the actual fixes were trivial). I
> have to go out to eat, but when I get back, I'll re-write the test using
> java 6 and commit. I attached the patch that I attempted to commit to
> the JIRA (in case anyone wants to take a look and help me guess why it
> works in 1.5 but fails when run in 6.0).


My guess is that it has nothing to do with the JDK version, but has to do
with the state of the classpath while the tests are being run. Your test
code does not handle the case in which your target URL is not found in the
classpath, and if that happened, it would result in an NPE on the line of
code that caused an NPE in Bamboo...

--
Martin Cooper



> Again sorry!
>
> -Wes
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message