struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Al Sutton" <al.sut...@alsutton.com>
Subject Re: [struts-dev] [S2.1] One Step On.... the Dojo plugin tree problem
Date Thu, 31 Jan 2008 09:41:08 GMT
Dale,

Thanks for the tips. I've updated the ftl file with a default that works 
with a null returned by the child property, so I'll be putting a patch into 
JIRA.

Al.

----- Original Message ----- 
From: "Dale Newfield" <Dale@Newfield.org>
To: "Struts Developers List" <dev@struts.apache.org>
Sent: Wednesday, January 30, 2008 8:07 PM
Subject: Re: [struts-dev] [S2.1] One Step On.... the Dojo plugin tree 
problem


> Dale Newfield wrote:
>> A previous example has a three character solution: 
>> https://issues.apache.org/struts/browse/WW-2383 , for this one it appears 
>> that a single "!" may be sufficient.
>>
>> Excerpted from 
>> <http://freemarker.org/docs/dgui_template_exp.html#dgui_template_exp_missing_default>:

>> If the default value is omitted, then it will be empty string and empty 
>> sequence and empty hash at the same time.
>
> Now that I read it again, the single character addition would probably 
> have been sufficient for the previous bug, too.  If we want to be 
> explicit, I think "![]" will use an empty sequence as the default value 
> here, but it seems unnecessary (and from the docs I'm still unclear 
> whether that syntax is valid).
>
> -Dale
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message