struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From LesleyT <lesley....@macquarie.com>
Subject Running Struts 2.0.11 on Weblogic 8.1 SP5
Date Wed, 02 Jan 2008 02:05:59 GMT

Hi all,

Am trying to run our application built using:
Struts 2.0.11, Spring 2.0, Hibernate 3.2 on WL 8.1 sp5.

I've read that some people have successfully run a struts2 app on weblogic
and would like to know how you got it up and running.

I retrotranslated the JARs below:
xwork-j4-2.0.4.jar
struts2-core-j4-2.0.11.jar
struts2-spring-plugin-j4-2.0.11.jar
ognl-j4-2.6.11.jar
freemarker-2.3.8.jar

Are there any other JARs you need to J4 for WL 8.1 ?

But for some reason I don't get consistent errors coming from the
application. 

I've had a couple of issues which don't happen consistently on my weblogic
deployed war files:
* spring's contextloaderlistener not loading any beans
* parse exceptions when the xmlconfigurationprovider parses the
struts-default.xml 
* null pointer exceptions when our app uses struts tags

Does anyone hav any advice on how they got their app working on weblogic 8.1
?

Thanks,
Lesley
-- 
View this message in context: http://www.nabble.com/Running-Struts-2.0.11-on-Weblogic-8.1-SP5-tp14572621p14572621.html
Sent from the Struts - Dev mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message