struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank W. Zammetti" <fzli...@omnytex.com>
Subject Re: Use the Source, Luke!
Date Wed, 05 Dec 2007 13:14:36 GMT
Niall Pemberton wrote:
> Looks like core uses JDK 1.5 features - for example the
> IllegalStateException constructors which take a "Throwable" cause were
> only added in JDK 1.5:
> 
>     http://java.sun.com/j2se/1.5.0/docs/api/java/lang/IllegalStateException.html
> 
> I don't remember agreeing to move to JDK 1.5 (from JDK 1.4) for the
> next Struts (1.4) version - but perhaps we did?

I had a feeling that might have been the case, but I too don't remember 
even discussion of requiring 1.5 at any point so I figured I must be wrong.

And I can confirm that switching to java5 works, got a successful build 
now... actually, I have java6 installed so I used that, but I assume 
java5 would work too.

Frank

> Niall

Frank

--
Frank W. Zammetti
Founder and Chief Software Architect
Omnytex Technologies
http://www.omnytex.com
AIM/Yahoo: fzammetti
MSN: fzammetti@hotmail.com
Author of "Practical Ajax Projects With Java Technology"
  (2006, Apress, ISBN 1-59059-695-1)
and "JavaScript, DOM Scripting and Ajax Projects"
  (2007, Apress, ISBN 1-59059-816-4)
Java Web Parts - http://javawebparts.sourceforge.net
  Supplying the wheel, so you don't have to reinvent it!

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message