struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Petrelli" <antonio.petre...@gmail.com>
Subject Re: Hold 2.0.10
Date Tue, 11 Sep 2007 07:57:48 GMT
2007/9/11, Ted Husted <husted@apache.org>:
>
> On 9/10/07, Antonio Petrelli <antonio.petrelli@gmail.com> wrote:
> > 2007/9/10, Ted Husted <husted@apache.org>:
> > > I got distracted last night, but I'll give it another try tonight.
> >
> > I just ported the release plugin configuration to the 2_0_X branch.
> > If you want, you can use the 2.1.x wiki as a reference to create the
> release.
>
> I tried it, but the process stuck on my gpg passphrase. The problem is
> probably with the configuration of my machine. When I do it the
> old-fashion way, I have to enter my credentials for every artifact.
> The error I get is
>
>     [INFO] One or more required plugin parameters are invalid/missing
> for 'gpg:sign'
>
>     [0] inside the definition for plugin: 'maven-gpg-plugin'specify
> the following:
>
>     <configuration>
>       ...
>       <passphrase>VALUE</passphrase>
>     </configuration>
>
>     -OR-
>
>     on the command line, specify: '-Dpassphrase=VALUE'
>
> I do have the passphrase in my settings.xml file, and I also tried
> passing it from the command line, under both cgywin and Windows, with
> no success.



I don't know if it is useful, but it seems that the parameter is "
gpg.passphrase" and not "passphrase".

Antonio

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message