struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Husted" <hus...@apache.org>
Subject Re: SmartURLs (fork of s2: problem with codebehind plugin)
Date Fri, 07 Sep 2007 10:37:43 GMT
I tried building it from source, using 1.6, under Eclipse, and the
problem is that a dependency on "net.java.lang.URLClassLoaderResolver"
was introduced between ".05" and .14 in the DefaultResultMapBuilder. I

In the build.xml and IntelliJ files there are a number of dependencies
on various products. I tried to check a few of those, like Savant, but
I didn't see the needed class.

-Ted.

On 9/7/07, Jim Cushing <jimothy@mac.com> wrote:
> It looks like the plugin requires Java 1.6; I have tried running it
> under 1.6 yet, but that may be the issue.
>
> On Sep 6, 2007, at 7:53 PM, Ted Husted wrote:
>
> > When deploying the SmartUrls plugin, my system is unable to find
> > the class
> >
> >  net.java.lang.URLClassLoaderResolver;
> >
> > I tried to google it without success.
> >
> > Can anyone tell me where this class might be found?
> >
> > It's used by the DefaultResultMapBuilder class.
> >
> > -Ted.
> >
> > On 9/6/07, Ted Husted <husted@apache.org> wrote:
> >> On 9/4/07, Brian Pontarelli <brian@pontarelli.com> wrote:
> >>>  BTW, I'm planning on releasing 1.0 of SmartURLs this week and
> >>> doing some
> >>> announcements to lists and such. Are these still plans on pulling
> >>> that back
> >>> into core?
> >>
> >> I'm trying out 0.14 now.
> >>
> >> Should there be any problem trying it in an application that already
> >> has some content, like the Blank application? Or is it either-or?
> >>
> >> -Ted.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message