struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mraible <m...@raibledesigns.com>
Subject Maven dependencies and tools.jar
Date Thu, 26 Jul 2007 15:51:10 GMT

Mornin' fellas,

An AppFuse user reported the following issue with Struts 2.0.9 today:



> I am tried to build my application with Maven 2.0.7 and I got this error:
> 
> 26/07/07 12h36min59s GMT-03:00: Missing:
> 1) com.sun:tools:jar:1.5.0
>   Try downloading the file manually from the project website.
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=com.sun -DartifactId=tools \
>           -Dversion=1.5.0 -Dpackaging=jar -Dfile=/path/to/file
>   Path to dependency:
>       1) br.com.bluesoft.tec2:tec2-web:war:2.0.0
>       2) org.apache.struts:struts2-core:jar:2.0.9
>       3) com.sun:tools:jar:1.5.0
> 1 required artifact is missing.
> for artifact:
>   br.com.bluesoft.tec2:tec2-web:war:2.0.0
> from the specified remote repositories:
>   appfuse (http://static.appfuse.org/repository),
>   central (http://repo1.maven.org/maven2),
>   bluesoft (http://www.bluesoft.com.br/maven2)
> 

Does Struts 2 have a dependency on tools.jar? If so, shouldn't something
like the following be used?

http://maven.apache.org/general.html#tools-jar-dependency

Thanks,

Matt
-- 
View this message in context: http://www.nabble.com/Maven-dependencies-and-tools.jar-tf4152498.html#a11813371
Sent from the Struts - Dev mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message