struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Germuska" <...@germuska.com>
Subject Re: [S2] Freemarker 2.3.8? ( was Re: [S2] Freemarker Confusion)
Date Mon, 22 Jan 2007 15:55:28 GMT
I'm also going to run my local development with a dependency on FM 2.3.8.  I
reviewed the release notes and there are no obvious compatibility issues,
plus, of course, a handful of bug fixes.  It seems to have been stable for
almost six months, so it seems safe for us to move to it.

Do we have any heuristics for deciding when to change versions of
dependencies?  For projects with a strong commitment to backwards
compatibility, it should generally make sense to move forward pretty
directly with minor releases, but considering how many external dependencies
we have, it seems like "rules" or some semblance thereof might be helpful.

Joe


On 1/21/07, Ted Husted <husted@apache.org> wrote:
>
> We've been running against freemarker 2.3.4. Has anyone tried using 2.3.8?
>
> Should we update our dependency from 2.3.4 to 2.3.8 ?
>
> * http://freemarker.org/docs/app_versions.html
>
> It's been out since July. I'm updating some training materials, and
> I'll try it here locally.
>
> -Ted.
>
> On 1/20/07, Joe Germuska <joe@germuska.com> wrote:
> >I see now that the syntax I was trying to use was
> > added in Freemarker 2.3.7
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
>
>


-- 
Joe Germuska
Joe@Germuska.com * http://blog.germuska.com

"The truth is that we learned from João forever to be out of tune."
-- Caetano Veloso

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message