struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Brown <mr...@twdata.org>
Subject Re: [S2] Struts 2.0.2 Build - ON HOLD
Date Tue, 05 Dec 2006 03:23:56 GMT
I don't know - you are the one that wrote the patch :)  If we need to 
break the new ajax tag to keep backward compatibility for the 2.0.2 
release, I can live with it.  Are there any examples in the showcase 
that would be broken if we reverted the anchor tag behavior?

Don

Musachy Barroso wrote:
> The problem is that for the ajax stuff it needs "buildUrl" to generate 
> the
> right url, is there anything we can do to keep them both working?
>
> musachy
>
> On 12/4/06, Don Brown <mrdon@twdata.org> wrote:
>>
>> Musachy Barroso wrote:
>> > Before the anchor tag was processing the href attribute like this:
>> >
>> > addParameter("href", findString(href));
>> >
>> > after the changes for the ajax tags, they are all processing the href
>> > like this:
>> >
>> >  addParameter("href", UrlHelper.buildUrl(findString(href), request,
>> > response, null));
>> Ok, then that's the problem.  When generating a url via the URL tag, it
>> already calls that buildUrl method, so it shouldn't be called again by
>> the Anchor tag.  We should back that change out as it breaks existing
>> behavior.  In general, please do be careful not to change how a tag
>> works, as we are going for a fully backwards compatible release in
>> 2.0.x, or at least as close as we can get.
>>
>> Don
>> >
>> > but I can't figure out what is the relationship between Anchor and URL
>> >
>> > musachy
>> >
>> > Don Brown wrote:
>> >> From what I can tell, the recent patch WW-1485 broke, or at least
>> >> changed, the anchor tag.  The url is being generated correctly,
>> >> however, the anchor tag is incorrectly processing the url a second
>> >> time.  Rainer applied the patch, so perhaps he might know how to fix
>> it?
>> >>
>> >> Don
>> >>
>> >> Ted Husted wrote:
>> >>> I just filed
>> >>>
>> >>> * https://issues.apache.org/struts/browse/WW-1537
>> >>>
>> >>> Links in the showcase that refer to namespaces are rendering the
>> >>> webapp root twice.
>> >>>
>> >>> * 
>> http://localhost:8080/struts2-showcase/struts2-showcase/tags/non-ui/
>> >>>                                   ^^^^                      ^^^^
>> >>> The problem breaks a lot of the showcase links, and is going to 
>> break
>> >>> links in other applications that use namespaces or paths in URL 
>> links.
>> >>>
>> >>> It might be something simple, but we should fix it before tagging a
>> >>> build.
>> >>>
>> >>> For now, I'm going to look at other things in the Showcase, in the
>> >>> hope someone has a quick solution to WW-1537.
>> >>>
>> >>> -Ted.
>> >>>
>> >>> 
>> ---------------------------------------------------------------------
>> >>> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>> >>> For additional commands, e-mail: dev-help@struts.apache.org
>> >>>
>> >>>
>> >>
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>> >> For additional commands, e-mail: dev-help@struts.apache.org
>> >>
>> >>
>> >
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>> > For additional commands, e-mail: dev-help@struts.apache.org
>> >
>> >
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>> For additional commands, e-mail: dev-help@struts.apache.org
>>
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message