struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David H. DeWolf" <ddew...@apache.org>
Subject Re: [tiles2] AttributeTag.preprocessAttribute disappearance
Date Mon, 06 Nov 2006 15:12:19 GMT
Works for me. . .go for it!

Antonio Petrelli wrote:
> David H. DeWolf ha scritto:
>> Can you help me understand why those created from the factory are 
>> "consistent"?
> 
> Err... I am not that sure... I think that preprocessing should happen 
> also to "configured" attributes, I thought that 
> ComponentDefinitionsImpl.resolveAttributes fixed the attributes, but it 
> seems that it doesn't.
> 
>> We definitely could do this type of thing at creation time - for both 
>> those defined through the tag and those defined through the factory.  
>> I don't really have a strong opinion either way, but my inclination 
>> would be to resolve the unspecified type 'just in time'. . .
> 
> Ok, then I think that "preprocessAttribute" should be re-put.
> 
>>
>> 2) Accept this small overhead in order to allow this property to morph 
>> as new definitions are registered.
>>
>> What I don't think we want is to require the tag to differentiate 
>> between tag created definitions and container created definitions.
>>
>> Agree?
> 
> Ok, but leave SB-49 open, so maybe one day we will fix it.
> 
> Ciao
> Antonio
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message