struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Brown <mr...@twdata.org>
Subject Re: debug=console and profiling=yes in Struts 2.0.1
Date Wed, 25 Oct 2006 16:30:32 GMT
Hmm...it looks like you don't have the debugging and profiling 
interceptors in your stack for that action.  Otherwise, the console and 
profiling properties would be removed correctly from the parameters and 
you wouldn't see that output.  Are you extending the "struts-default" 
package and using its stack, or rolling your own?

Don

Matt Raible wrote:
> With debug=console, I get:
>
> ERROR - OgnlValueStack.setValue(176) | Error setting expr 'console'
> with value '[Ljava.lang.String;@2bf86'
> java.lang.RuntimeException: No object in the CompoundRoot has a
> publicly accessible property named 'console' (no setter could be
> found).
>        at 
> com.opensymphony.xwork2.util.CompoundRootAccessor.setProperty(CompoundRootAccessor.java:67)

>
>        at ognl.OgnlRuntime.setProperty(OgnlRuntime.java:1629)
>        at ognl.ASTProperty.setValueBody(ASTProperty.java:105)
>        at ognl.SimpleNode.evaluateSetValueBody(SimpleNode.java:177)
>        at ognl.SimpleNode.setValue(SimpleNode.java:246)
>
> Adding <s:head/> at the top of my page doesn't seem to help. Neither
> does disabling sitemesh.
>
> If I add ?profiling=yes, I get:
>
> ERROR - ParametersInterceptor.setParameters(180) | Developer
> Notification (set webwork.devMode to false to disable this message):
> No object in the CompoundRoot has a publicly accessible property named
> 'console' (no setter could be found).
> ERROR - CompoundRootAccessor.setProperty(66) | No object in the
> CompoundRoot has a publicly accessible property named 'profiling' (no
> setter could be found).
> ERROR - OgnlValueStack.setValue(176) | Error setting expr 'profiling'
> with value '[Ljava.lang.String;@3941dd'
> java.lang.RuntimeException: No object in the CompoundRoot has a
> publicly accessible property named 'profiling' (no setter could be
> found).
>        at 
> com.opensymphony.xwork2.util.CompoundRootAccessor.setProperty(CompoundRootAccessor.java:67)

>
>
> Matt
>
>
> On 10/24/06, Don Brown <mrdon@twdata.org> wrote:
>> What is puzzling is that profiling isn't working.  When you append
>> "profiling=yes" to the query string, Struts will start printing out
>> profiling information to the log.  If you have a lot of logging
>> messages, these profiling statements might be lost among the clutter.
>> For the debugging console, try turning Sitemesh off, either through
>> removing its filter or excluding its decorator for the page.  Take a
>> look at the HTML generated to ensure that new markup is being inserted
>> correctly.  Finally, are you using any custom results to render the 
>> page?
>>
>> Don
>>
>> Matt Raible wrote:
>> > On 10/24/06, Don Brown <mrdon@twdata.org> wrote:
>> >> Those errors are fine, actually, although it is true they should be
>> >> cleaned up to minimize confusion.  Do you get the OGNL console popup?
>> >
>> > No.
>> >
>> >> If not, I'm guessing you are using sitemesh?
>> >
>> > Yes.
>> >
>> >> We did the demo at ApacheCon with the starter archetype app, which
>> >> also uses
>> >> Sitemesh, so it can work.
>> >
>> > Maybe it's an issue with Prototype/Scriptaculous?  I tried removing
>> > Scripaculous, but no dice.
>> >
>> >>
>> >> Also, check that Struts 2 has devMode=true set in 
>> struts.properties in
>> >> WEB-INF/classes.  The debugging and profiling support are only 
>> enabled
>> >> in dev mode.
>> >
>> > Yep, I have that.
>> >
>> > Matt
>> >
>> >>
>> >> Don
>> >>
>> >> Matt Raible wrote:
>> >> > I'm trying to use some features I found in Don Brown's 
>> presentation on
>> >> > Struts 2.0 at ApacheCon.  Using debug=console and profiling=yes
>> >> > doesn't seem to work.
>> >> >
>> >> > When I use debug=console, I get:
>> >> >
>> >> > ERROR - ParametersInterceptor.setParameters(180) | Developer
>> >> > Notification (set webwork.devMode to false to disable this 
>> message):
>> >> > No object in the CompoundRoot has a publicly accessible property 
>> named
>> >> > 'debug' (no setter could be found).
>> >> > ERROR - CompoundRootAccessor.setProperty(66) | No object in the
>> >> > CompoundRoot has a publicly accessible property named 'debug' (no
>> >> > setter could be found).
>> >> > ERROR - OgnlValueStack.setValue(176) | Error setting expr 
>> 'debug' with
>> >> > value '[Ljava.lang.String;@74997a'
>> >> > java.lang.RuntimeException: No object in the CompoundRoot has a
>> >> > publicly accessible property named 'debug' (no setter could be 
>> found).
>> >> >
>> >> > Any ideas?
>> >> >
>> >> > Thanks,
>> >> >
>> >> > Matt
>> >> >
>> >> > 
>> ---------------------------------------------------------------------
>> >> > To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>> >> > For additional commands, e-mail: dev-help@struts.apache.org
>> >> >
>> >> >
>> >>
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>> >> For additional commands, e-mail: dev-help@struts.apache.org
>> >>
>> >>
>> >
>> >
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>> For additional commands, e-mail: dev-help@struts.apache.org
>>
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message