struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tm jee <tm_...@yahoo.co.uk>
Subject Re: Ognl a new dependency?
Date Mon, 04 Sep 2006 02:51:45 GMT
> I did things similar to this, as well as removing xwork2 from my
 > (locally built) .m2/repository.  Thanks for the tip, seems to be
 > working now.

 Glad its working now. I occationally get myself stuck in such situation as well. :-)
 
----- Original Message ----
From: Matt Raible <mraible@gmail.com>
To: Struts Developers List <dev@struts.apache.org>; tm jee <tm_jee@yahoo.co.uk>
Sent: Sunday, 3 September, 2006 2:51:19 PM
Subject: Re: Ognl a new dependency?

On 9/3/06, tm jee <tm_jee@yahoo.co.uk> wrote:
> Could it be that the ognl jar in your local maven repository is being corrupted?
>
> Does a clean compile work eg.

I did things similar to this, as well as removing xwork2 from my
(locally built) .m2/repository.  Thanks for the tip, seems to be
working now.

Matt

>
> mvn clean compile ?
>
> ----- Original Message ----
> From: Matt Raible <mraible@gmail.com>
> To: Struts Developers List <dev@struts.apache.org>
> Sent: Saturday, 2 September, 2006 10:36:53 PM
> Subject: Ognl a new dependency?
>
> For some reason, my builds against 2.0.0 were fine - until I svn
> updated this evening.  Now I get:
>
> java.lang.NoClassDefFoundError: ognl/ClassResolver
>         at com.opensymphony.xwork2.ActionContext$ActionContextThreadLocal.initialValue(ActionContext.java:328)
>         at java.lang.ThreadLocal$ThreadLocalMap.getAfterMiss(ThreadLocal.java:374)
>
> After adding the following to my pom.xml:
>
>         <dependency>
>             <groupId>ognl</groupId>
>             <artifactId>ognl</artifactId>
>             <version>2.6.9</version>
>         </dependency>
>
> I get:
>
> << ERROR!
> java.lang.NoClassDefFoundError
>         at com.opensymphony.xwork2.ActionContext$ActionContextThreadLocal.initialValue(ActionContext.java:328)
>         at java.lang.ThreadLocal$ThreadLocalMap.getAfterMiss(ThreadLocal.java:374)
>
> Is something up with struts2 and xwork2 being out of synch?
>
> Thanks,
>
> Matt
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
>
>
>
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org






Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message