struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Brown <mr...@twdata.org>
Subject Re: Issues upgrading from WebWork 2.2.3 to Struts 2.0.0 (SVN)
Date Wed, 30 Aug 2006 18:27:13 GMT
Matt Raible wrote:
> On 8/30/06, Ted Husted <husted@apache.org> wrote:
>> On 8/30/06, Matt Raible <mraible@gmail.com> wrote:
>> > I believe this is the correct forum,
>>
>> Yep.
>>
>> > I had to remove this reference in struts-default.xml for things to 
>> work.
>>
>> Thanks, I removed that in r438570, so don't bother with a ticket.
>
> I just did an update on core/src/main/resources/struts-default.xml and
> it's still there:
>
>            <result-type name="jasper"
> class="org.apache.struts2.views.jasperreports.JasperReportsResult"/>
>
> ...
> U    core/src/main/resources/struts-default.xml
> Updated to revision 438573.
The jasper reports result _should_ be there, however, we do need to 
reduce the warn message to perhaps an info.  The idea is we should list 
results that may not be available to make it easy to use the new results 
when the struts-extras.jar is present.
>
>>
>> > struts.compatibilityMode.WebWork=true
>>
>> If you update to the current head, or tomorrow morning's nighly JAR,
>> you can remove this setting now.
>>
>
> What does it do?
>
>> > Messages:       The default() is not defined in action class
>> > org.appfuse.webapp.action.FileUploadAction
>>
>> Is there a default method in that class?
>
> No, there's a doDefault() method - which worked fine with WebWork.
> default is a keyword, so I can't have a default() method.  I can try
> renaming my method, but it seems that backwards compatibility has been
> broken.
Yes, this is true - we removed support for do* methods.  Perhaps in this 
one case, however, we should allow a doDefault method.  Create a ticket 
for it.   Perhaps do* support itself should be put back in, but only be 
enabled when in compatibility mode.

Don
>
>
>>
>> Did that used to map to execute or something in WW? If so, it doesn't
>> anymore, and we need to add that to the release notes.
>
> Yes, using !methodName in WW delegated to doMethodName().  Is the "do"
> prefix deprecated or simply not implemented?
>
> Matt
>
>>
>> -Ted.
>>
>> On 8/30/06, Matt Raible <mraible@gmail.com> wrote:
>> > I believe this is the correct forum, but if I should ask 2.0.0
>> > questions on the user mailing list (or in IRC), please let me know.
>> >
>> > I was successfully able to upgrade AppFuse from WW 2.2.2 to 2.2.3 w/o
>> > any issues.  I then tried to upgrade to Stuts 2.0.0 (from SVN) and had
>> > the following issues:
>> >
>> > 1. WARN - XmlConfigurationProvider.verifyResultType(298) | Result
>> > class [org.apache.struts2.views.jasperreports.JasperReportsResult]
>> > doesn't exist (ClassNotFoundException) at result-type -
>> > 
>> file:/opt/dev/Tools/jakarta-tomcat-5.0.28/work/Catalina/localhost/appfuse-struts/loader/struts-default.xml:23:108,

>>
>> > ignoring
>> > java.lang.ClassNotFoundException:
>> > org.apache.struts2.views.jasperreports.JasperReportsResult
>> >
>> > I had to remove this reference in struts-default.xml for things to 
>> work.
>> >
>> > Index: struts-default.xml
>> > ===================================================================
>> > --- struts-default.xml  (revision 438253)
>> > +++ struts-default.xml  (working copy)
>> > @@ -20,8 +20,6 @@
>> >              <result-type name="plaintext"
>> > class="org.apache.struts2.dispatcher.PlainTextResult" />
>> >
>> >              <!-- third party integration -->
>> > -            <result-type name="jasper"
>> > class="org.apache.struts2.views.jasperreports.JasperReportsResult"/>
>> > -
>> >              <result-type name="jsf"
>> > class="org.apache.struts2.jsf.FacesResult" />
>> >          </result-types>
>> >
>> > 2. When I try to go to
>> > http://localhost:8080/appfuse/uploadFile!default.html, I get the
>> > following error:
>> >
>> > Struts Problem Report
>> >
>> > The Struts has detected an unhandled exception:
>> > Messages:       The default() is not defined in action class
>> > org.appfuse.webapp.action.FileUploadAction
>> > File:   com/opensymphony/xwork2/DefaultActionInvocation.java
>> > Line number:    337
>> > Stacktraces
>> > java.lang.IllegalArgumentException: The default() is not defined in
>> > action class org.appfuse.webapp.action.FileUploadAction
>> >
>> > I have the following in struts.properties:
>> >
>> > struts.compatibilityMode.WebWork=true
>> >
>> > As well as in FileUploadAction.java, I have:
>> >
>> >     public String doDefault() {
>> >         return INPUT;
>> >     }
>> >
>> > Am I doing something wrong here?  Should I enter these issues into 
>> JIRA?
>> >
>> > Thanks,
>> >
>> > Matt
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>> > For additional commands, e-mail: dev-help@struts.apache.org
>> >
>> >
>>
>>
>> -- 
>> HTH, Ted.
>> * http://www.husted.com/struts/
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message