struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <>
Subject [Struts Wiki] Trivial Update of "RoughSpots" by MartinCooper
Date Sat, 22 Apr 2006 17:41:04 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Struts Wiki" for change notification.

The following page has been changed by MartinCooper:

The comment on the change is:
Add link to Retroweaver

    * [crazybob] +1 for JDK 1.5 since it came out. I have a lot of code I could contribute
which depends on the new concurrency libraries, etc.
    * [MJ] With JDK 1.5 as a requirement for SAF2-based projects, users may be inclined to
take a look at [ Stripes] first. It
is compact, it features event-dispatching, built-in validation and conversion, Action and
!ActionForm being one entity, and it allows to forgo XML config files by using annotations.
The last feature alone is worth sack o'gold. If SAF2 is going to require JDK 1.5, it should
allow XML-free configuration, at least for simple use cases.
    * [plightbo] I use JDK 1.5 as well. I think we really should think about doing this. Non-1.5
options exist (WebWork 2.2 and Struts 1.3), and we're really at a close point where it is
no longer unreasonable to require 1.5 (1.6 will have been out for almost 6 months by the time
we hit a final release).
-   * [mrdon] I'd like to use Java 5, but use retroweaver to continue to support 1.4.  If
we keep XML in addition to annotations, that should be very doable.
+   * [mrdon] I'd like to use Java 5, but use [ Retroweaver]
to continue to support 1.4.  If we keep XML in addition to annotations, that should be very
      * [crazybob] Sounds good. We'll also need to handle JDK-1.5 only APIs (concurrency for
    * [Gabe] I am required to use 1.4 at work. To me the question of whether to require 1.5
comes down to whether the same shops that are stuck using 1.4 are also not going to let people
use Struts 2.0, because it is too bleeding edge anyway. In that case it doesn't make sense
to allow 1.4, because the only people who would be using it would also have access to 1.5
anyway. I don't know if that is the case though.
    * [martinc] The big issue with the JDK version is app servers. This comes in two parts.
First is whether all of the major app server vendors have products available that support
the desired SDK version. I believe we're OK in that regard with JDK 1.5. The bigger issue
is customer acceptance. Enterprise customers, especially, tend to standardise on their app
server, and they are not quick to upgrade. Unless the application vendor has a great deal
of influence over the customer's infrastructure, the vendor has to live with whatever app
server version is in use at the customer site. It is rare, then, that the application vendor
can dictate the JDK version. On the other hand, the customer usually couldn't care less what
version of Struts the application was built with.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message