struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Struts Wiki] Update of "RoughSpots" by MichaelJouravlev
Date Wed, 19 Apr 2006 00:12:18 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Struts Wiki" for change notification.

The following page has been changed by MichaelJouravlev:
http://wiki.apache.org/struts/RoughSpots

The comment on the change is:
Plugged in EventActionDispatcher information

------------------------------------------------------------------------------
  
    1. `TextProvider` is a bad name. The JDK refers to these as "messages" everywhere.
  
-   1. Come up with a clean way to separate "view" actions from "update" actions. For example,
you may have `view()` and `update()` methods in the same action class. Right now XWork has
`MethodFilterInterceptor`, but that's not a very clean solution. You don't want validation
or the `DefaultWorkflowInterceptor` to run for the `view()` method. My current project has
separate interceptor stacks, but it would be nice if there was some first class support for
this. We could flag action invocations as "view" or "update" (using an enum). We could automatically
choose a mode based on whether the request is an HTTP GET or POST. Or we could set the mode
based on an annotation on the action method. Or some other way...
+   1. Come up with a clean way to separate "view" actions from "update" actions. For example,
you may have `view()` and `update()` methods in the same action class. Right now XWork has
`MethodFilterInterceptor`, but that's not a very clean solution. You don't want validation
or the `DefaultWorkflowInterceptor` to run for the `view()` method. My current project has
separate interceptor stacks, but it would be nice if there was some first class support for
this. We could flag action invocations as "view" or "update" (using an enum). We could automatically
choose a mode based on whether the request is an HTTP GET or POST. Or we could set the mode
based on an annotation on the action method. Or some other way... (MJ: Using GET for render
and POST for submit works well unless you want to trigger event with a link. Also, these links
might help: DataEntryForm, EventActionDispatcher)
  
    1. On the OGNL value stack `#request` refers to request attributes and `#parameters` refers
to the parameters. I think we should rename these `#request` for request parameters and `#requestAttributes`
for request attributes.
  

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message