struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexandru Popescu" <the.mindstorm.mailingl...@gmail.com>
Subject Re: WebWork renaming strategy *revised*
Date Sat, 25 Mar 2006 10:21:30 GMT
IMO we should keep the names as consistent as possible so my vote would go
for:

 - com.opensymphony.webwork package -> org.apache.struts.action2
 - WebWork* classes -> Struts*
- WebWork in comments, documentation -> Struts Action 2
- webwork. as the configuration properties prefix -> struts.
- ww: tag prefix -> a:/saf:

so pretty much as Rainer's vote.

./alex
--
.w( the_mindstorm )p.


On 3/25/06, Rainer Hermanns <hermanns@aixcept.de> wrote:
>
> Don,
>
> I think using Struts Ti on the one hand and Struts Action 2 on the other
> as a name will lead to some confusion. Ti as a codename is great, but for
> the codebase I would prefer Action2.
>
> >  - com.opensymphony.webwork package -> org.apache.struts.ti
> >  - WebWork* classes -> Struts*
> >  - WebWork in comments, documentation -> Struts Action 2
> >  - webwork. as the configuration properties prefix -> struts.
> >  - ww: tag prefix -> a:
>
> +1 for this proposal but with package name 'org.apache.struts.action2'
> +1 for either a: or saf:
>
> cheers,
> Rainer
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message