struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 37685] - Javascript tag does not work on Mozilla
Date Tue, 07 Mar 2006 13:48:11 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=37685>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=37685





------- Additional Comments From niallp@apache.org  2006-03-07 13:48 -------
I tried this in Mozilla 1.7.12 with the struts-examples webapp and couldn't 
reproduce it - once all valid values were entered the Javascript validation 
succeeded.

I then tried your example, as you say, it showed "false" for (test == 1) - but 
when I pasted your example into the struts validation function though, it 
showed "true". After playing around a while I found that I could reproduce 
this issue in the validation function if I removed type="text/javascript" from 
the <script> element - also your example started working [i.e. (test == 1) 
showed "true"] when I added type="text/javascript" to the <script> element.

The one difference between my tests and yours are that I used Mozilla 1.7.12 
and you used 1.7.11 - so I guess there is a possibility something changed 
between versions.

At this point, I don't want to change something for a bug I can't reproduce. 
Can you see if you can reproduce it with the struts-examples webapp?

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message