struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 31509] - html:javascript tag doesn't work right with jsFunctionName set
Date Sun, 03 Oct 2004 19:31:08 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=31509>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=31509

html:javascript tag doesn't work right with jsFunctionName set

niallp@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|Major                       |Enhancement



------- Additional Comments From niallp@apache.org  2004-10-03 19:31 -------
You're right, I didn't notice that server side you are still using the 
standard 'required' validator - I focused on the javascript.

I agree with you its confusing and there arnen't any docs telling people how to 
code their own validators - but then again, the existing validators are fairly 
good models for people who want to implement their own.

This is only an issue, because you want to use the standard stuff server side 
and your own custom stuff client side. Simplest approach IMO, would be to set 
up your own validateRequiredFullMsg method which just calls the 
FieldChecks.validateRequired() method.

I agree with you that documenting it would be good - if you fancy submitting a 
patch for the user guide, that would be great. Alternatively, you could set up 
a "How To" on the wiki which would also be good.

The reason the original patch can't be done is not because of backward 
compatibility, its because the javascript isn't part of Struts - you would need 
to get Commons Validator to change the naming of the two  types of functions 
first.

Having said that, neither that approach or adding another 'method' name don't 
seem worth it to me - I've changed this to an enhancement rquest and I'll leave 
it open in case someone else thinks differently and picks it up.

Niall

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message