struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Craig McClanahan <craig...@gmail.com>
Subject Re: [VOTE] Move minimum to 2.3 (was Re: Changing how CommonsMultipartRequestHandler handles text parameters?)
Date Fri, 03 Sep 2004 16:24:05 GMT
On Fri, 3 Sep 2004 06:29:59 -0700 (PDT), David Graham
<grahamdavid1980@yahoo.com> wrote:
> <snip>
> > Either it could be developed with compatibility to existing JDK versions
> > and
> > keep everyone happy. or go with JDK 1.5 and my preferernce would be to
> > go to
> > JDK 1.5 and use all those favorite-new-features.
> 
> In the past we have required the Java version that the Servlet spec
> required.  Why would we want to require 1.5 when Servlet 2.4 requires 1.4?
>  IMO, it's simpler and more consistent to follow the Servlet spec with
> regards to Java version.

It would be easier to be consistent with the specs if *they* were
consistent :-).

Servlet 2.4 and JSP 2.0 require JDK 1.4 if you're in a J2EE 1.4
container (indirectly, because it's the J2EE spec that says this). 
For standalone web containers, the minimum platform is JDK 1.3.

It's not just open source projects that have spirited discussions
about when to switch :-).

> 
> David

Craig

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message