struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Wessendorf" <maili...@matthias-wessendorf.de>
Subject RE: Struts-faces
Date Mon, 05 Jul 2004 15:39:38 GMT
i think it will be better (perhaps for now)
to compile against servlet 2.3

jsf-deployment-guide tells people howto run jsf (the RI)
in 1.3 or 1.4-j2ee-containers.

so if struts-faces is build against 2.4
people run into problems, when they *must*
use 1.3-webcontainer (e.g. tomcat)

on my box struts-faces from cvs (incl. patch for 2.3)
runs in tomcat5 with RI and MyFaces.

so, i don't know the complexity of changing
on nightly-build-box the dependency from 2.4
to 2.3

btw. there is another dependency in struts-faces
it builds against struts1.1
with 1.2 there is a problem too... (it is a known issue)
FormComponent.java has a problem with method
"createDynaActionFormClass()" of class 
"DynaActionFormClass"

Matthias

> -----Original Message-----
> From: Ted Husted [mailto:husted@apache.org] 
> Sent: Monday, July 05, 2004 5:17 PM
> To: Struts Developers List
> Subject: RE: Struts-faces
> 
> 
> I imagine Craig has Struts-Faces compiling against 2.4 to 
> make sure it stays in synch with Tomcat 5. 
> 
> But, the question is whether we want to mandate that 
> Struts-Faces can only compile against 2.3 (and not 2.4)? Or 
> vice-versa. Or is there a way to write the class so it 
> compiles under either? 
> 
> I know this is a pain. We went through the same problem with 
> DataSources between 2.2 and 2.3. I'm not sure what the issue 
> here is, but for DataSources, the interface changed and we 
> had to stub the new members so that they threw exceptions if 
> called. Of course, the problem with that approach is it may 
> obviate new functionality or rely on deprecated methods. 
> 
> -Ted.
> 
> On Mon, 05 Jul 2004 14:14:02 +0200, Matthias Wessendorf wrote:
> > James,
> >
> > i also guess it is the result of the commitment.
> > i submitted (first) a wrapper, that builds against 2.4 
> reason is, the 
> > build-porperties had *default* to 2.4
> >
> > okay ted asks for a 2.3-wrapper, so i created that candidate.
> >
> > i think the wrapper should compile against 2.3
> > since jsf is able to run in j2ee1.3-containers
> >
> > So i am wondering, why struts-faces uses 2.4
> > for compiling.
> >
> > btw. the 2.3 wrapper runs on servlet2.4-containers (like tomcat5.0)
> >
> > Matthias
> >
> >
> >> I think it is happening because of the changes I committed 
> for your 
> >> fix for MyFaces.  If you look at when the builds stopped, 
> it's right 
> >> after I made the commits on 6/29.  It must be an issue of what 
> >> version of servlet.jar that the HttpServletRequestWrapper class is 
> >> being compiled against. Is it not possible to make that class 
> >> compilable against both 2.3 and 2.4?
> >>
> >> -James
> >>
> >>
> >> -----Original Message-----
> >> From: Matthias Wessendorf [mailto:mailings@matthias- 
> wessendorf.de] 
> >> Sent: Monday, July 05, 2004 6:29 AM To: dev@struts.apache.org 
> >> Subject: Struts-faces
> >>
> >> see http://cvs.apache.org/builds/jakarta-struts/nightly/struts-
> >> faces/
> >>
> >>
> >> the nightly build is empty again,
> >>
> >>
> >> so is there a logfile, where i can check, why it is not build 
> >> successful?
> >>
> >> Cheers,
> >>
> >>
> >> --
> >> Matthias We├čendorf
> >> Aechterhoek 18
> >> DE-48282 Emsdetten
> >> Germany
> >> Email: matthias AT wessendorf DOT net
> >> URL: http://www.wessendorf.net
> >>
> >>
> >> ------------------------------------------------------------------
> >> --- To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org For 
> >> additional commands, e-mail: dev-help@struts.apache.org
> >>
> >>
> >> ------------------------------------------------------------------
> >> --- To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org For 
> >> additional commands, e-mail: dev-help@struts.apache.org
> >
> >
> > --------------------------------------------------------------------
> > - To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org For 
> > additional commands, e-mail: dev-help@struts.apache.org
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
> For additional commands, e-mail: dev-help@struts.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message