struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Holmes" <ja...@jamesholmes.com>
Subject RE: James Holmes:is this related? RE: [bug?] <html:base> tag and mozilla
Date Thu, 17 Jun 2004 00:23:55 GMT
One more thing...

I'm trying to understand the use case for the base tag in the first place.
Browsers automatically use the URL of the page as the base URL.

On second thought I think I know why it is needed, but feel free to explain
if you have a sec.

-James

-----Original Message-----
From: Michael Rasmussen [mailto:rasmusmc1@hotmail.com] 
Sent: Wednesday, June 16, 2004 7:16 PM
To: 'Struts Developers List'
Subject: James Holmes:is this related? RE: [bug?] <html:base> tag and
mozilla


James,
  Here is the thread I was talking about.
Michael
-----Original Message-----
From: Lesaint Sébastien [mailto:lesaint@ginlex.com] 
Sent: Thursday, June 10, 2004 9:50 AM
To: Struts Developers List
Subject: RE: [bug?] <html:base> tag and mozilla

As I described, my problem was related to Mozilla and the way it handled the
html <base> tag.
To solve the problem: 
 - I assume that none of the my website viewers will use mozilla (kind of
stupid, imo)
 - I remove the html <base> tag from my pages
 - I modify the baseTag class so that the displayed URI in the page does not
contain the file name (therefore Mozilla will be unable to request a page
that should not and cause errors)
 - I notify the Mozilla developer community of this problem and ask them
their opinion

For the time being, I'm using the second solution. But, as I think the html
<base> tag is quite useful to the browser to resolve relative links, I don't
think it is good long-term solution.

What's your opinion about this?

-- 
Seb'

PS.: what's the meaning of "w/o" (in "[...] who would use JSF (much less
struts-faces) w/o real design tools?" for example)?


-----Message d'origine-----
De : Michael Rasmussen [mailto:rasmusmc1@hotmail.com] 
Envoyé : jeudi 10 juin 2004 15:25
À : dev@struts.apache.org
Objet : RE: [bug?] <html:base> tag and mozilla

We were hearing about problems with struts-faces users and the html:base 
tag.  thought it was a faces problem.  This may chnage that thought.
Thanks
Michael


>From: Lesaint Sébastien <lesaint@ginlex.com>
>Reply-To: "Struts Developers List" <dev@struts.apache.org>
>To: Struts Developers List <dev@struts.apache.org>
>Subject: RE: [bug?] <html:base> tag and mozilla
>Date: Thu, 10 Jun 2004 15:27:50 +0200
>
>Hi,
>
>I'm using Struts and Tiles. Never heard of struts-faces, so...
>
>-----Message d'origine-----
>De : Michael Rasmussen [mailto:rasmusmc1@hotmail.com]
>Envoyé : jeudi 10 juin 2004 14:32
>À : dev@struts.apache.org
>Objet : RE: [bug?] <html:base> tag and mozilla
>
>Seb'
>Are you using struts-faces or just struts?
>Michael
>
>
>From: Lesaint Sébastien <lesaint@ginlex.com>
> >Reply-To: "Struts Developers List" <dev@struts.apache.org>
> >To: dev@struts.apache.org
> >Subject: [bug?] <html:base> tag and mozilla
> >Date: Thu, 10 Jun 2004 10:32:05 +0200
> >
> >
> >Hello guys,
> >
> >I don't know if this is really a bug, at least it is an issue that I 
>think
> >you should be aware of (if not already).
> >
> >When developing a webApp, I came into a very weird struts logging 
>problem.
> >After investigation, it appeared that my problem was related to a
> >particular
> >behaviour of Mozilla against other browsers (IE and Opera, as far as I
> >tested). I don't know if this is a Mozilla issue or a <html:base> struts
> >tag
> >issue.
> >
> >I enclosed a piece of the discussion that occurred on the struts-user
> >mailing list. The first part describes mozilla's behaviour, then it
> >describes my code.
> >
> >Let me know if this is of any help.
> >
> >--
> >Seb'
> >
> >-----Message d'origine-----
> >De : Lesaint Sébastien
> >Envoyé : lundi 7 juin 2004 20:45
> >À : Struts Users Mailing List
> >Objet : [SOLVED]RE: odd errors certainly related to Tiles and/or Struts,
> >occurs o nly with Mozilla
> >
> >Hello all,
> >
> >I finally found out where this problem came from when I check the access
> >log
> >of the server.
> >
> >As you could see in the code snippets, I use the <html:base> tag in the
> >header of the jsp file I use as the view component (pageModelTest.jsp).
> >The resulting HTML tag is
> >"http://www.myserver.com/webApp/layout/defaultPageModel.jsp".
> >What Mozilla does and other browser don't is requesting the page
> >"http://www.myserver.com/webApp/layout/defaultPageModel.jsp", IE for
> >example
> >only request "http://www.myserver.com/webApp/layout/".
> >
> >I don't know exactly why browsers send a request to URI defined in the 
>base
> >tag, but the result is that the server processes the page in the case of
> >Mozilla, causing errors in the tiles tags.
> >Tiles tags in the defaultPageModel.jsp page are all using the "name"
> >attribute, therefore awaiting a value to do the include. Because of the
> >direct request on the defaultPageModel.jsp page, there isn't even a
> >component context, causing uncaught exceptions (null pointer exceptions
> >because of the missing context or "org.apache.jasper.JasperException: 
>Error
> >- tag.getAsString : component context is not defined").
> >
> >So, I'm quite happy I found where the problem came from, but I still need
> >to
> >solve it.
> >
> >My questions are then the followings:
> >  - In general, is the HTML <base> tag really useful ? Required for the
> ><html:link> and <html:url> tags maybe ?
> >  - If the <html:base> tag is necessary, how can I force Struts to write
> >"http://www.myserver.com/webApp/layout/" instead of
> >"http://www.myserver.com/webApp/layout/defaultPageModel.jsp", solving my
> >mozilla problem ?
> >
> >
> >Hope this message can help some people and that I could get some answer
> >about the base tag.
> >
> >--
> >Seb'
> >
> >-----Message d'origine-----
> >De : Lesaint Sébastien
> >Envoyé : lundi 7 juin 2004 18:06
> >À : Struts Users Mailing List
> >Objet : RE: odd errors certainly related to Tiles and/or Struts, occurs o
> >nly with Mozilla
> >
> >Thanks for your answer, but it doesn't make sense. I tried it though, it
> >doesn't work :)
> >I can't call http://www.myserver.com/webApp/login.do anymore if I use it.
> >
> >-----Message d'origine-----
> >De : Johannes Wolfgang Woger [mailto:jwwoger@chello.at]
> >Envoyé : lundi 7 juin 2004 17:04
> >À : Struts Users Mailing List
> >Objet : Re: odd errors certainly related to Tiles and/or Struts, occurs o
> >nly with Mozilla
> >
> >
> >
> >Lesaint Sébastien wrote:
> >
> > >Hi,
> > >
> > >A little more information.
> > >
> > >My investigation lead me to the conclusion that this error is somehow
> > >related to Tiles includes.
> > >
> > >When requesting the page with mozilla, I noticed there is a delay 
>between
> > >the time the text is visible and the time the browser stop loading and
> >the
> > >error is logged on the server. It might not be relevant though...
> > >
> > >I reproduced the bug with the minimum code.
> > >------------------------------------
> > >I'm using a Struts action forwarding to a Tiles def, my struts-config 
>has
> > >the following code :
> > ><action forward="tilesDef.pageModel.test" path="/login" />
> > >
> >try
> ><action forward="/login" path="tilesDef.pageModel.test"/>
> >
> >Wolfgang
> >
> > >
> > >------------------------------------
> > >The Tiles def is as follow in the Tiles-def.xml file :
> > ><definition name="tilesDef.pageModel.test"
> >path="/layout/pageModelTest.jsp">
> > >	<put name="pageFooter" value="/footer.jsp" />
> > ></definition>
> > >
> > >------------------------------------
> > >The pageModelTest.jsp page :
> > ><%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
> > ><%@ taglib uri="/WEB-INF/struts-tiles.tld" prefix="tiles" %>
> > >
> > ><html:html>
> > ><head>
> > > <html:base />
> > ></head>
> > ><body topmargin="0" leftmargin="0" bgcolor="#FFFFFF">
> > >
> > >
> > ><table border="0" cellspacing="0" cellpadding="0">
> > ><tr>
> > > 	<td><tiles:insert attribute="pageFooter" flush="true" /></td>
> > >	<td width="1"><img src="" width="1" height="1"></td>
> > ></tr>
> > ></table>
> > >
> > ></body>
> > ></html:html>
> > >------------------------------------
> > >
> > >Note : the bug does not appear when pageModelTest.jsp does not contain
> >the
> > ><tiles:insert> tag.
> > >
> > >------------------------------------
> > >The footer.jsp page :
> > ><br><br>
> > ><center><i>Copyright my company</i></center>
> > >
> > >Note : the bug does not appear when I directly request footer.jsp.
> > >
> > >
> > >I'm completely clueless on the subject now... :(
> > >
> > >Please help,
> > >
> > >
> > >
> >
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> >For additional commands, e-mail: user-help@struts.apache.org
>
>_________________________________________________________________
>Watch the online reality show Mixed Messages with a friend and enter to win
>a trip to NY
>http://www.msnmessenger-download.click-url.com/go/onm00200497ave/direct/01/
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
>For additional commands, e-mail: dev-help@struts.apache.org

_________________________________________________________________
Check out the coupons and bargains on MSN Offers! http://youroffers.msn.com


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@struts.apache.org
For additional commands, e-mail: dev-help@struts.apache.org


Mime
View raw message