struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maya menon <maya_j...@yahoo.com>
Subject Struts help
Date Fri, 19 Mar 2004 15:35:17 GMT
Hi,
I am using struts with WSAD for creating my web application.
I have a jsp page which intern calls a css file and displays images 
also.
when I call my jsp: , test1.jsp, the 
page displays fine and I can see the i,ages and the css file also takes 
effect.
 
Now, I added an action mapping, updateAction in my struts config file

<action-mappings>

<action name="update" path="/update" scope="request" 
type="com.test.testweb.actions.UpdateAction">

<forward name="success" path="/jsp/Test1.jsp">

</forward>

</action>

</action-mappings>
Here, when I added the action mapping, I am forwarding to the same 
page, test1.jsp after a success. ie, my form is getting submitted and I am 
coming to the same page. 
 
But when the same page gets displayed again, the images are not getting 
displayed and its not recognising the css file.
My console gives the following errors:
 
[3/19/04 9:16:40:408 CST] 154a763c OSEListenerDi E PLGN0021E: Servlet 
Request Processor Exception: Virtual Host/WebGroup Not Found : The web 
group /images/logo.gif has not been defined
 
Why is this happening ?
 
Do I need to add anything so that the images and css files are 
recognised from an action link ?
 
Thanks


Do you Yahoo!?
Yahoo! Mail - More reliable, more storage, less spam
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message