struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Husted <hus...@apache.org>
Subject Re: Unable to compile the source.
Date Fri, 02 Jan 2004 11:47:51 GMT
On Thu, 01 Jan 2004 22:59:03 -0800, Anand Stephen wrote:
> Greetings,
> Wish you all a very happy new year!
>
> I am trying to compile the latest source of struts I have attached
> the error log.   Any help would be appreciated,   -anand      
>
> ---
> Outgoing mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.557 / Virus Database: 349 - Release Date: 12/30/2003

To build Struts with Ant, you need to create a build.properties file based on the build.properties.sample
in CVS, and acquire all the dependencies it mentions. 

The dependency your message complains about is a missing servlet.jar. As mentioned, this are
shipped with your container (e.g. Tomcat). Tomcat 4 ships it in $TOMCAT\common\lib.

One short cut is to getting started is to use the JARS  in the lib folder from Struts 1.1
and add the new JARs from there. 

Another shortcut would be to install Maven (maven.apache.org) and use the new Maven setup.
It's still under development, but it do work. :) 

HTH, Ted.



---------------------------------------------------------------------
To unsubscribe, e-mail: struts-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-dev-help@jakarta.apache.org


Mime
View raw message