struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hus...@apache.org
Subject cvs commit: jakarta-struts/doc/userGuide installation.xml
Date Fri, 06 Jun 2003 22:03:35 GMT
husted      2003/06/06 15:03:35

  Modified:    doc/userGuide installation.xml
  Log:
  Update for FileUpload RC1 dependancy and latest JAXP information.
  
  Revision  Changes    Path
  1.27      +19 -21    jakarta-struts/doc/userGuide/installation.xml
  
  Index: installation.xml
  ===================================================================
  RCS file: /home/cvs/jakarta-struts/doc/userGuide/installation.xml,v
  retrieving revision 1.26
  retrieving revision 1.27
  diff -u -r1.26 -r1.27
  --- installation.xml	28 Feb 2003 06:42:21 -0000	1.26
  +++ installation.xml	6 Jun 2003 22:03:35 -0000	1.27
  @@ -46,10 +46,12 @@
   
     <li><strong>XML Parser</strong> - Struts <b>requires</b>
the presence of an XML
         parser that is compatible with the Java API for XML Parsing (JAXP)
  -      specification, 1.1 or later.  You can download and install the JAXP
  -      <a href="http://java.sun.com/xml">reference implementation</a>,
  -      which is required for building the Struts source distribution.  In
  -      Struts-based web applications, you may replace the reference
  +      specification, 1.1 or later. This is bundled with J2SE 1.4 and later.
  +      (For earlier versions of Java, the easiest way to obtain JAXP is
  +      probably by downloading the Web Services Developers Kit
  +      (1.1 or later!).See the <a href="http://java.sun.com/xml/jaxp/faq.html#jaxp-ri-latest">
  +      Sun JAXP FAQ</a> for more information.)
  +      In Struts-based web applications, you may replace the reference
         implementation classes with any other JAXP compliant parser, such as
         <a href="http://xml.apache.org/xerces-j">Xerces</a>.  See detailed
         instructions related to the parser in the instructions for
  @@ -83,35 +85,31 @@
     <li>
         <strong>Jakarta Commons Packages</strong> - Struts utilizes several
         packages from the <a href="http://jakarta.apache.org/commons/">Jakarta
  -      Commons Project</a>. 
  -      These are the packages which must be available if you you wish to 
  +      Commons Project</a>.
  +      These are the packages which must be available if you you wish to
         build Struts from source:
         <ul>
         <li><em>Beanutils</em> (Version 1.5 or later)</li>
         <li><em>Collections</em> (Version 2.1 or later)</li>
         <li><em>DBCP</em> (Version 1.0 or later)</li>
         <li><em>Digester</em> (Version 1.3 or later)</li>
  -      <li><em>FileUpload</em> (Recent 
  -        <a href="http://jakarta.apache.org/builds/jakarta-commons/nightly/commons-fileupload">
  -        Nightly Build</a>)</li>
  +      <li><em>FileUpload</em> (1.0 RC1 or later)</li>
         <li><em>Lang</em> (Version 1.1 or later)</li>
  -      <li><em>Logging</em> (Recent 
  -        <a href="http://jakarta.apache.org/builds/jakarta-commons/nightly/commons-logging">
  -        Nightly Build</a>, or Version 1.0.3 or later when it is available)</li>
  +      <li><em>Logging</em> (Version 1.0.3 or later when it is available)</li>
         <li><em>Pool</em> (Version 1.0.1 or later)</li>
         <li><em>Validator</em> (Version 1.0.1 or later) </li>
         </ul>
  -      For your convenience, the requisite JARs are provided as a single 
  -      download under the <code>lib</code> sub-directory with each release 
  -      and beta distribution. 
  -      Please note that the minimum requirements may change between releases 
  -      and betas, and some JARs may need to be updated to use the latest 
  -      Nightly Build. 
  +      For your convenience, the requisite JARs are provided as a single
  +      download under the <code>lib</code> sub-directory with each release
  +      and beta distribution.
  +      Please note that the minimum requirements may change between releases
  +      and betas, and some JARs may need to be updated to use the latest
  +      Nightly Build.
     </li>
   
  -  <li><strong>Jakarta ORO</strong> - 
  -  <a href="http://jakarta.apache.org/oro/index.html">Apache Jakarta ORO</a>

  -  version 2.06 (or later) is  required to build Struts from source.</li>  
  +  <li><strong>Jakarta ORO</strong> -
  +  <a href="http://jakarta.apache.org/oro/index.html">Apache Jakarta ORO</a>
  +  version 2.06 (or later) is  required to build Struts from source.</li>
   
     <li><strong>Xalan XSLT Processor</strong> - If you are building Struts
from
         the source distribution, you will need a version of Xalan to perform
  
  
  

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-dev-help@jakarta.apache.org


Mime
View raw message