struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 20432] - Validator returns nulls in JavaScript validation
Date Wed, 04 Jun 2003 13:30:22 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20432>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20432

Validator returns nulls in JavaScript validation





------- Additional Comments From matt@raibledesigns.com  2003-06-04 13:30 -------
I get the same behavior on the server-side.  I found that my validator.jsp (used
for javascript) had the following error:

java.lang.NullPointerException
	at org.apache.commons.validator.ValidatorResources.get(ValidatorResources.java:333)
	at
org.apache.struts.taglib.html.JavascriptValidatorTag.doStartTag(JavascriptValidatorTag.java:316)
	at org.apache.jsp.validator_jsp._jspx_meth_html_javascript_0(validator_jsp.java:74)
	at org.apache.jsp.validator_jsp._jspService(validator_jsp.java:53)
	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:137)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

This file's contents is as follows and works fine in the 03026 build:

<%@ page language="java" contentType="javascript/x-javascript" %>
<%@ taglib uri="http://jakarta.apache.org/struts/tags-html" prefix="html" %>

<html:javascript dynamicJavascript="false" staticJavascript="true"/>

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-dev-help@jakarta.apache.org


Mime
View raw message