struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karr, David" <David.K...@wamu.net>
Subject RE: Status check?
Date Fri, 06 Jun 2003 20:09:36 GMT
Perhaps a "-target 1.2" option should be specified on our "javac"
targets?  I would guess the number of issues with down-compilation from
1.4 to 1.2 is very small, but if we have one in our code base, the
compiler won't tell us about it.

> -----Original Message-----
> From: Hajratwala, Nayan (N.) [mailto:nhajratw@ford.com]
> 
> >-----Original Message-----
> > From: Martin Cooper [mailto:martinc@apache.org]
> >
> > "Ted Husted" <husted@apache.org> wrote in message
> > news:3EE0BDA1.7060309@apache.org...
> > > Our installation page says our dependency is J2SE 1.2 or later.
> > >
> > > Does that mean I should compile the binary distribution
> > under the latest
> > > J2SE 1.2, or should I use the latest J2SE 1.4?
> >
> > I have been building the releases using J2SE 1.4 for some
> > time now, and I
> > would recommend sticking with that. Going with 1.4 ensures we get
the
> > benefits of the latest compiler improvements. The
> > compatibility issue is
> > with the JVM rather than the compiler - we want to be able to
> > run on J2SE
> > 1.2, but we don't need to build the releases with that.
> 
> I don't believe this is correct.  I think it actually is the COMPILER
that
> can cause a compatibility issue.  There is an article over at Java
World
> that details this problem.  The first example makes it clear.
> 
> http://www.javaworld.com/javaqa/2003-05/02-qa-0523-version.html?

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-dev-help@jakarta.apache.org


Mime
View raw message