struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18032] - <html:img> tag appending session doesn't work with apache setup
Date Fri, 16 May 2003 10:43:27 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18032>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18032

<html:img> tag appending session doesn't work with apache setup

Stefan.Kuehnel@frontis.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|WONTFIX                     |



------- Additional Comments From Stefan.Kuehnel@frontis.com  2003-05-16 10:43 -------
Apache 1.x seems to well within spec not to support the ";sessionid=xxx" syntax
as the HTML specification only recommends support for ";" to separate request
parameters:

----------------------------

B.2.2 Ampersands in URI attribute values

The URI that is constructed when a form is submitted may be used as an
anchor-style link (e.g., the href attribute for the A element). Unfortunately,
the use of the "&" character to separate form fields interacts with its use in
SGML attribute values to delimit character entity references. For example, to
use the URI "http://host/?x=1&y=2" as a linking URI, it must be written <A
href="http://host/?x=1&#38;y=2"> or <A href="http://host/?x=1&amp;y=2">.


We recommend that HTTP server implementors, and in particular, CGI implementors
support the use of ";" in place of "&" to save authors the trouble of escaping
"&" characters in this manner.
[http://www.w3.org/TR/html401/appendix/notes.html]

----------------------------

So while Apache provides workarounds via mod_rewrite, I find it unnecessary to
require everyone to reconfigure their web server, when such a simple fix exists
for which even a patch has been provided.

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-dev-help@jakarta.apache.org


Mime
View raw message