struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 19595] New: - password check need minlength and maxlength support
Date Fri, 02 May 2003 14:40:37 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19595>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19595

password check need minlength and maxlength support

           Summary: password check need minlength and maxlength support
           Product: Struts
           Version: Nightly Build
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Validator Framework
        AssignedTo: struts-dev@jakarta.apache.org
        ReportedBy: r_q_d@yahoo.com


The minlength and maxlength check only support text and textarea. 

The password minlength and maxlength check is also required.

In order to support this, we need to change the validation-rules.xml from 

                    if (field.type == 'text' ||
                        field.type == 'textarea') {

To
                    if (field.type == 'text' ||
                        field.type == 'textarea' ||
                        field.type == 'password') {

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-dev-help@jakarta.apache.org


Mime
View raw message