struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18599] New: - HTML Textarea tag renders without leading return (a '\n')
Date Wed, 02 Apr 2003 07:31:03 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18599>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18599

HTML Textarea tag renders without leading return (a '\n')

           Summary: HTML Textarea tag renders without leading return (a
                    '\n')
           Product: Struts
           Version: 1.1 RC1
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Unknown
        AssignedTo: struts-dev@jakarta.apache.org
        ReportedBy: r.de.wit@barito.nl


The rendered textarea resulting from a html:textarea does not contain a leading
'\n' or return character. When the browser is sending the content of the
rendered textarea, it removes a leading '\n' character.

<!-- fooBarProperty contains  '\n  Foo, Bar' -->
<html:textarea property="fooBarProperty"/>  results in:
<textarea>
  Foo, Bar<textarea>

This results in '  Foo, Bar' being send as content by the browser, but it should
be sending '\n  Foo, Bar'. This problem can be resolved by rendering the
<textarea> with a '\n' after the start-tag. The rendered textarea should be:

<textarea>

  Foo, Bar</textarea>

This result in '\n  Foo, Bar' being send as content of the textarea, which is
correct.

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-dev-help@jakarta.apache.org


Mime
View raw message