struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Graham" <dgraham1...@hotmail.com>
Subject Remove DBCP dependency for 1.2?
Date Thu, 06 Mar 2003 03:58:31 GMT
Struts has 6 open bug reports, many of which I'm prepared to mark as later.  
What's disheartening is the large number of open bugs on the dependent 
packages we use from commons.  We need DBCP for 1.1 to maintain backwards 
compatibility with deprecated 1.0 APIs but we don't need it for 1.2 (when we 
remove those deprecated APIs).

Many Struts users use container provided DataSources and other means of 
connection pooling.  I think we should drop the DBCP dependency for 1.2 and 
let people that need it download it seperately.

Thoughts?

David





_________________________________________________________________
The new MSN 8: advanced junk mail protection and 2 months FREE*  
http://join.msn.com/?page=features/junkmail


---------------------------------------------------------------------
To unsubscribe, e-mail: struts-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-dev-help@jakarta.apache.org


Mime
View raw message