struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Husted <hus...@apache.org>
Subject BasicDataSource and 1.0
Date Sun, 05 Jan 2003 22:08:42 GMT
Is there any reason why the Commons BasicDataSource 1.0 (Pool 1.1) 
shouldn't work with Struts 1.0?

If I try swappingin it in, using the different properties as documented, 
my results come back null. I tried stepping thru, but there's a lot 
going on in there =:0)

I also tried retrofitting the GenericDataSource wrapper into my code 
base, but with the same result.

I'd like to clean-up the database FAQ and it would be good to know 
whether we should be able to use the Commons BasicDataSource with both 
versions or not.

Here's the config I was trying (in 1.0.2):

    <data-source
         type="org.apache.commons.dbcp.BasicDataSource">
         <set-property
           property="defaultAutoCommit"
           value="true" />
         <set-property
           property="defaultReadOnly"
           value="false" />
         <set-property
           property="driverClassName"
             value="org.gjt.mm.mysql.Driver"/>
         <set-property
           property="maxActive"
           value="10" />
         <set-property
           property="maxWait"
           value="5000" />
         <set-property
             property="password"
             value="********"/>
         <set-property
           property="url"
             value="jdbc:mysql://192.168.42.147:3306/gavel_dummy"/>
         <set-property
             property="username"
             value="********"/>
         <set-property
             property="validationQuery"
             value="SELECT COUNT(*) FROM gavel_keys"/>
     </data-source>

(Stars replace the login values.)

-T.

-- 
Ted Husted,
Struts in Action <http://husted.com/struts/book.html>



--
To unsubscribe, e-mail:   <mailto:struts-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-dev-help@jakarta.apache.org>


Mime
View raw message