struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 15044] - Taglib - Index Attribute in html:Checkbox doesn't set correctly
Date Mon, 20 Jan 2003 01:42:18 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15044>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15044

Taglib - Index Attribute in html:Checkbox doesn't set correctly

turner@blackbear.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |INVALID



------- Additional Comments From turner@blackbear.com  2003-01-20 01:42 -------
This is a known problem with checkboxes in general with HTML/JSP.  You need to 
make sure that your ActionForm has a reset method, and that the reset method 
clears any checkbox values to false.  For example, the following code snippet 
will make your code work:

    public void reset(ActionMapping mapping, HttpServletRequest request) {
        for (int i = 0; i < regions.length; i++) {
            regions[i].setIsSelected(false);
        }

    }

I just fully tested indexed checkboxes, and they work fine.

--
To unsubscribe, e-mail:   <mailto:struts-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-dev-help@jakarta.apache.org>


Mime
View raw message