struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cedric Dumoulin <ced...@apache.org>
Subject Re: Switching Modules - isn't working for me...
Date Mon, 30 Dec 2002 15:20:31 GMT

  Does someone have a simple example war file reproducing the problem ? 
If yes, could you send it to me ?

  Cedric

Matt Raible wrote:

>I tried switching to last night's build, but that appears to be even
>worse - I can't even use the default module.  I get the following error
>the first time (and all other times) I hit an action:
>
>----- Root Cause -----
>java.lang.AbstractMethodError
>	at
>org.apache.struts.action.ActionServlet.initModulePlugIns(ActionServlet.j
>ava:1096)
>	at
>org.apache.struts.action.ActionServlet.init(ActionServlet.java:470)
>	at javax.servlet.GenericServlet.init(GenericServlet.java:256)
>
>My log file never shows any modules getting initialized (save '').  The
>last build I had, from 11-24, the default app worked, just the switching
>didn't.  Are there any sample applications I can prove this works
>against?
>
>Thanks,
>
>Matt
>
>  
>
>> -----Original Message-----
>>From: 	Matt Raible [mailto:matt@raibledesigns.com] 
>>Sent:	Friday, December 27, 2002 1:37 AM
>>To:	'struts-user@jakarta.apache.org'
>>Subject:	Switching Modules - isn't working for me...
>>
>>It's late, so it's possible my problem is something small and 
>>I just need a second set of eyes on it.  I am trying to 
>>configure my application have an "upload" module.  I'm 
>>following the instructions at 
>>http://jakarta.apache.org/struts/userGuide/configuration.html#
>>module_config-switching.
>>
>>In my <global-forwards>, I have the following forward:
>>
>>        <!-- Switch to upload sub-application -->
>>        <forward name="uploadResume" contextRelative="true"
>>            path="/upload/index.do" redirect="true" />
>>
>>I have my ActionServlet configured as follows:
>>
>>        <init-param>
>>            <param-name>config</param-name>
>>            <param-value>/WEB-INF/struts-config.xml</param-value>
>>        </init-param>
>>        <init-param>
>>            <param-name>config/upload</param-name>
>>            <param-value>/WEB-INF/struts-upload.xml</param-value>
>>        </init-param>
>>
>>And struts-upload.xml has the following action-mappings:
>>
>>        <!-- Router to upload tiles definition -->
>>        <action
>>            path="/index"
>>            type="org.apache.struts.actions.ForwardAction"
>>            parameter="upload"/>
>>        
>>        <!-- Upload Action -->
>>        <action    path="/uploadFile"
>>                   type="org.appfuse.webapp.actions.UploadAction"
>>                   name="uploadForm"
>>                  scope="request"
>>                  input="upload">
>>            <forward name="success" path="display" />
>>       </action>
>>
>>Where "upload" and "display" are tiles definitions.  When I 
>>try to access this forward (either via link or direct URL), I get:
>>
>>Tomcat 404: The requested resource (/appfuse/upload) is not available.
>>
>>And in the log file:
>>
>>INFO [Thread-4] 
>>[org.apache.struts.util.PropertyMessageResources] 
>>PropertyMessageResources.<init>(127) | Initializing, c
>>onfig='com.fgm.web.menu.displayer.DisplayerStrings', returnNull=true
>>INFO [Thread-4] 
>>[org.apache.struts.tiles.TilesRequestProcessor] 
>>TilesRequestProcessor.initDefinitionsMapping(154) | Tile
>>s definition factory found for request processor '/upload'.
>>INFO [Thread-4] [org.apache.struts.action.RequestProcessor] 
>>RequestProcessor.process(225) | Processing a 'GET' for path
>>'/index'
>>DEBUG [Thread-4] [org.apache.struts.action.RequestProcessor] 
>>RequestProcessor.processActionCreate(305) |  Looking for Ac
>>tion instance for class org.apache.struts.actions.ForwardAction
>>DEBUG [Thread-4] [org.apache.struts.action.RequestProcessor] 
>>RequestProcessor.processActionCreate(321) |   Creating new
>>Action instance
>>DEBUG [Thread-4] [org.apache.struts.action.RequestProcessor] 
>>RequestProcessor.processForwardConfig(428) | processForward
>>Config(ForwardConfig[name=null,path=upload,redirect=false,cont
>>    
>>
>extRelative=true])
>  
>
>>
>>Any ideas?
>>
>>Thanks,
>>
>>Matt
>>
>>
>>    
>>
>
>  
>


--
To unsubscribe, e-mail:   <mailto:struts-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-dev-help@jakarta.apache.org>


Mime
View raw message