struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 15734] New: - <html:form cannot find the action form
Date Tue, 31 Dec 2002 04:49:58 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15734>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15734

<html:form  cannot find the action form

           Summary: <html:form  cannot find the action form
           Product: Struts
           Version: 1.1 Beta 2
          Platform: PC
        OS/Version: Other
            Status: NEW
          Severity: Minor
          Priority: Other
         Component: Custom Tags
        AssignedTo: struts-dev@jakarta.apache.org
        ReportedBy: carol@ohnomytoe.com


This is probably a usage problem but the first sample finds the actionform ... 
and the second sample doesn't - implying that there is something awry with the 
struts-config file.

I'm using weblogic 6.1 with sp3.


--- in my jsp page
<html:form action="/sitemap.do" name="rptDetailForm"
type="gtri.metric.award.struts.RptDetailForm" focus="rptId">  ---- This
works


BUT

<html:form action="/sitemap.do"  focus="rptId">   ---- This does NOT


In the struts config I have ....
<form-beans>
               <form-bean name="rptDetailForm"
                          type="gtri.metric.award.struts.RptDetailForm">
		</form-bean>

and
	<action-mappings>
		<action path="/rptDetail"
		        type="gtri.metric.award.struts.RptDetailAction"
		        name="rptDetailForm"
		        scope="request"
		        validate="false"
                       input="/sitemap.jsp">
			<forward name="success"
			         path="/rptDetail.jsp"
			         redirect="false">
			</forward>
		</action>


The error I get is ...

<Dec 30, 2002 10:22:21 PM EST> <Error> <HTTP>
<[WebAppServletContext(-14703832,a
wWeb,/awWeb)] Root cause of ServletException
javax.servlet.jsp.JspException: Cannot retrieve definition for form bean
null
       at org.apache.struts.taglib.html.FormTag.lookup(FormTag.java:897)
       at
org.apache.struts.taglib.html.FormTag.doStartTag(FormTag.java:543)
       at jsp_servlet.__rptdetail._jspService(__rptdetail.java:223)
       at weblogic.servlet.jsp.JspBase.service(JspBase.java:27)
       at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm

see anything obvious????

--
To unsubscribe, e-mail:   <mailto:struts-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-dev-help@jakarta.apache.org>


Mime
View raw message