struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 8460] - using null="false" in message-resources adds alt & title element to generated html
Date Thu, 25 Jul 2002 13:59:04 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8460>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8460

using null="false" in message-resources adds alt & title element to generated html





------- Additional Comments From ScottCarlson@yahoo.com  2002-07-25 13:59 -------
I've seen this as well.  The tags are looking up a message resource "null" that 
isn't there, so it is returning a string as you asked it to.  

I'm guessing the "Right-thing-to-do" would be change all of the custom tags to 
not look up the message resource if no resource key is specified.  I'm guessing 
they check for null after the resource lookup now, which is why they don't 
return alt and title if the message resources are set to null=true.  

There is a simple 90% solution though.  Add the line "null=" to your 
appropriate ApplicationResources file.  You'll still get the alt and title 
tags, but they'll be render as alt="" and title="".

--
To unsubscribe, e-mail:   <mailto:struts-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-dev-help@jakarta.apache.org>


Mime
View raw message