struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 10955] New: - Error running struts-blank applicaiton under JRun 3.1
Date Thu, 18 Jul 2002 16:54:34 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10955>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10955

Error running struts-blank applicaiton under JRun 3.1

           Summary: Error running struts-blank applicaiton under JRun 3.1
           Product: Struts
           Version: 1.1 Beta 1
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Example
        AssignedTo: struts-dev@jakarta.apache.org
        ReportedBy: bdturner@lineone.net


When the struts-blank web applicaiton is deployed under JRun 3.1, initially I 
got a problem with the logging library that was solved by using the 
lastest commons-logging.jar (see Bugzilla 10501).

However, now when I restart the server, I get a new error message from the logs, 
which I have included below.

07/18 17:46:52 error (JRun) Could not pre-load servlet: action 
[javax.servlet.ServletException: Could not instantiate 
org.apache.struts.action.ActionServlet]
[1]java.lang.NullPointerException
	at 
org.apache.struts.util.MessageResources.getMessageResources(MessageResources.jav
a:558)
	at 
org.apache.struts.action.ActionServlet.initInternal(ActionServlet.java:989)
	at org.apache.struts.action.ActionServlet.init(ActionServlet.java:411)
	at javax.servlet.GenericServlet.init(GenericServlet.java:258)
	at 
allaire.jrun.servlet.JRunServletLoader.loadServletInstance(../servlet/JRunServle
tLoader.java:203)
	at 
allaire.jrun.servlet.JRunServletLoader.loadServletInstance(../servlet/JRunServle
tLoader.java:161)
	at 
allaire.jrun.servlet.JRunServletLoader.loadServlet(../servlet/JRunServletLoader.
java:149)
	at 
allaire.jrun.servlet.JRunSE.getServletReference(../servlet/JRunSE.java:1705)
	at 
allaire.jrun.servlet.JRunSE.preloadServlets(../servlet/JRunSE.java:1371)
	at allaire.jrun.servlet.JRunSE.init(../servlet/JRunSE.java:236)
	at allaire.jrun.ServletService.init(../ServletService.java:66)
<SNIP>

As mentioned in the previous Bugzilla, the v1.0.2 struts-blank example works 
fine under this setup.

--
To unsubscribe, e-mail:   <mailto:struts-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-dev-help@jakarta.apache.org>


Mime
View raw message