struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 10604] New: - Multiple <html:form> tags incorrectly render form name with tag pooling
Date Tue, 09 Jul 2002 18:32:18 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10604>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10604

Multiple <html:form> tags incorrectly render form name with tag pooling

           Summary: Multiple <html:form> tags incorrectly render form name
                    with tag pooling
           Product: Struts
           Version: 1.0.2 Final
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Custom Tags
        AssignedTo: struts-dev@jakarta.apache.org
        ReportedBy: rory.douglas@na.sunchem.com


I have a JSP page utilising two <html:form> tags, each linked to a distinct 
Form Bean (ie the form bean names are distinct in struts-config.xml). This page 
renders correctly on Tomcat 4.0.4 and 4.1.3.

However, on 4.1.6 and 4.1.7, the second tag renders incorrectly, the <form> tag 
getting the same name attribute as the first. This error can be corrected by 
disabling tag pooling in the 4.1.7 (and supposedly in 4.1.6, I haven't tried 
that yet).

I have tested with multiple 1.2-compliant tags on a single page on the above 
tag-pooling servers, and not experienced a problem.

--
To unsubscribe, e-mail:   <mailto:struts-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-dev-help@jakarta.apache.org>


Mime
View raw message