struts-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <>
Subject Re: New name for Components / Extended Templates?
Date Sat, 07 Jul 2001 20:47:07 GMT
On Wed, 27 Jun 2001, Cedric Dumoulin wrote:

>   Components / Extended Templates framework will be added to Struts
> shortly.
>   It is now the last chance to rename this framework if necessary.
> Primary idea of the framework was to allow building of JSP pages by
> assembling reusable pieces of code, called blocks or components. One of
> the aims is to provide a library of easily reusable components (like
> standard layouts, but also reusable menus, common login form, shopping
> card, ...).
>   Templating mechanism is naturally done with the framework, but
> framework can also provide a starting point for reusable components.
>   So what's wrong with name "components" ? Component is a broad term in
> English, and it may be confusing when people talk about Struts
> components in general. So maybe we should change actual Components
> framework name.
>   Why not renaming "Components" to "templates" ? Framework allow more
> than templating, If we call it "templates", I am afraid that people
> identify framework
> with only the template mechanism, missing the ability to define reusable
> piece of pages. Also, this would break the actual templates
> implementation.
>   After discussions with Ted Husted,  we propose following alternatives
> :

Note:  you can't use a dash in Java package names :-(

>  Framework name                     package name
>  JSP pieces / Extended Templates
>    (as a play on Java Faces ;-)     jsp-pieces or pieces
>  JSP Blocks                         jsp-blocks or blocks
>  Dynamic Templates                  templates
>   My preference goes to (JSP pieces / Extended Templates), jsp-pieces.
>   I need your opinion on this renaming :
>    * Do we really need to do it ? (A lot of peoples already use
>      components. This could lead to troubles)

I think we do.  Although we'll strive for backwards compatibility, the
fact that it's getting integrated as a first-class part of Struts is bound
to cause some sorts of incompatibilities.  Having a name change (and
continuing to support the stand-alone library for Struts 1.0 users) will
reduce confusion in the long run.

>    * Which name do you prefer / propose ?

Of the presented names, I like "pieces" the best.  The "blocks" term has
pretty definite connotations, at least for Java programmers :-).

Other alternatives to think about:

* "layouts" (although there was a separate "layouts" proposal
  a while back that might also be usefully integrated)

* "models" (although it's another really broad term)

* "patterns" (same issue, but closer to the intent?)

* "joists" (more whimsical, fitting the "Struts" theme, but
  doesn't really say anything about what it does :-)

>     Cedric


View raw message