streams-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Letourneau <jletournea...@gmail.com>
Subject Re: Streams Setup
Date Fri, 31 May 2013 19:55:30 GMT
We should also probably update the documentation for deploying to
Tomcat...I noticed it is currently heavily ServiceMix oriented.

On Fri, May 31, 2013 at 3:52 PM, Jason Letourneau
<jletourneau80@gmail.com> wrote:
> Hi Danny -
> If you mvn install the master-pom, then the project pom will be
> referencing .2 from your local repo (.1 is the released version in the
> apache repository).  The master-pom is already setup to require Java
> 1.6.  I am confused where you edited to require 1.6.
>
> Sorry for the missed step in the documentation - we should edit that.
>
> Jason
>
> On Fri, May 31, 2013 at 2:16 PM, Sullivan, Danny <dsullivan@mitre.org> wrote:
>> Hi,
>>
>> While setting up the project I found I had to make several adjustments to the master
pom. These changes are:
>>
>>
>>   1.  Changing "0.2-incubating-SNAPSHOT" to "0.1-incubating" (0.2 didn't exist in
the directory available)
>>   2.  Specifying the java version to 1.6 in the properties (maven tried using 1.3
which ran into problems compiling generics and annotations)
>>
>> I also found that I needed to run mvn install on the pom of the Streams Master which
isn't mentioned in the documentation. However, once I completed these steps the project setup
correctly. Is this something I should submit a patch for? I apologize for being new to this
process.
>>
>> Thanks,
>>
>> Danny
>>
>>

Mime
View raw message