streams-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Letourneau <jletournea...@gmail.com>
Subject Re: Startup errors on "streams-web"
Date Fri, 22 Feb 2013 01:12:22 GMT
Take a look at the usage link on the incubation page that has a basic test flow - also the
spring configs should get copied in from the eip component if you mvn install at the project
root

Jason

Sent from my iPhone

On Feb 21, 2013, at 7:41 PM, Craig McClanahan <craigmcc@gmail.com> wrote:

> On Wed, Feb 20, 2013 at 7:19 AM, Jason Letourneau
> <jletourneau80@gmail.com>wrote:
> 
>> Oh it could be complaining about trying to setup the servlet route
>> endpoint without a proper servlet container at its disposal?  Might
>> try looking at the properties for the eip routes module and using the
>> jetty:// endpoints instead of the servlet:// endpoint that is in the
>> streams-web properties file...don't have the code in front of
>> me...just guessing
>> 
>> On Wed, Feb 20, 2013 at 9:22 AM, Jason Letourneau
>> <jletourneau80@gmail.com> wrote:
>>> I've not tested with jetty, just with Tomcat and deploying the war.
>>> 
>>> But this seems like it can't find the Camel dependencies.
>>> 
>>> Jason
> 
> OK, deploying it in Tomcat made startup work, once I added an empty spring
> config file into the WEB-INF/spring folder (configuration logic complains
> if there are no spring*.xml files there at all).
> 
> Any hints on how to get this thing to do something interesting?  :-)
> 
> Craig

Mime
View raw message