stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anuruddha Premalal <anuruddhaprema...@gmail.com>
Subject Deployment section in cartridge definition is not getting saved?
Date Wed, 02 Sep 2015 04:58:41 GMT
Hi Devs,

I'm trying to add the following[1] single tenant tomcat cartridge to
stratos 4.1.1 via both api and UI. Even though it added successfully
deployment section is missing from the definition(I got the definition
using API). What would be the cause?.


[1] {
"type": "tomcat",
"category": "framework",
"provider": "apache",
"host": "appfactory.private.wso2.com",
"displayName": "Tomcat 7",
"description": "Tomcat 7 Cartridge",
"version": "7",
"multiTenant": false,
"loadBalancingIPType": "public",
"portMapping": [
{
"name": "http-8080",
"protocol": "http",
"port": 8080,
"proxyPort": 80,
"kubernetesPortType": "NodePort"
}
],
"iaasProvider": [
{
"type": "kubernetes",
"imageId": "wso2/tomcat:1.0.0",
"networkInterfaces": []
}
],
"property": [
{
"name": "payload_parameter.S2GIT_IP",
"value": "10.100.5.106"
},
{
"name": "payload_parameter.S2GIT_DOMAIN",
"value": "s2git.appfactory.private.wso2.com"
},
{
"name": "payload_parameter.START_CMD",
"value": "PCA"
}
],
"deployment": {
"baseDir": "/opt/tomcat/webapps",
"dir": []
}
}

Regards,
-- 
*Anuruddha Premalala (MIEEE)Mobile : +94710461070E-mail  :
anuruddhapremalal@gmail.com <anuruddhapremalal@gmail.com>web      :
www.anuruddha.org <http://www.anuruddha.org>Sri Lanka.*

Mime
View raw message