stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pranavan Theivendiram <pranavan...@cse.mrt.ac.lk>
Subject Re: Set up CEP with stratos externally
Date Mon, 17 Aug 2015 02:19:10 GMT
Hi Lasindu,

I have created new diff file and tried. I am getting the same error again.

Thanks

*T. Pranavan*
*BSc Eng Undergraduate| Department of Computer Science & Engineering
,University of Moratuwa*
*Mobile| *0775136836

On 17 August 2015 at 00:07, Lasindu Charith <lasindu@wso2.com> wrote:

> Hi Pranavan,
>
> The current stratos-cep-extension which is based on siddhi 2.0.0 is not
> compatible with CEP 3.1.0 (which is based on siddhi 2.1.0), due to some API
> changes.
> You may need to apply the diff in [1
> <https://issues.apache.org/jira/browse/STRATOS-866>] and build the CEP
> extension again, then use it with CEP 3.1.0.
>
> The reason why we did not upgrade it because siddhi 2.1.0 does not contain
> the fix we need for [2
> <https://issues.apache.org/jira/browse/STRATOS-1108>].
>
> [1] https://issues.apache.org/jira/browse/STRATOS-866
> [2] https://issues.apache.org/jira/browse/STRATOS-1108
> <https://issues.apache.org/jira/browse/STRATOS-1108>
>
> Thanks,
>
> On Mon, Aug 17, 2015 at 12:00 AM, Pranavan Theivendiram <
> pranavan.11@cse.mrt.ac.lk> wrote:
>
>> Hi lasindu. I am doing it for CEP 3.1
>> On Aug 16, 2015 11:55 PM, "Lasindu Charith" <lasindu@wso2.com> wrote:
>>
>>> Hi Pranavan,
>>>
>>> Are you trying to deploy extensions that have been written for
>>> Siddhi-2.0.0(CEP 3.0.0) in Siddhi 2.1.0(CEP 3.1.0)?
>>> If you are doing so, this error may occur due to incompatibility of
>>> versions. Could you please let us know more specifics about this custom
>>> execution plan?
>>>
>>>
>>> On Sun, Aug 16, 2015 at 11:46 PM, Lahiru Sandaruwan <lahirus@wso2.com>
>>> wrote:
>>>
>>>> + Ashan, Lasindu.
>>>>
>>>> On Sun, Aug 16, 2015 at 1:15 PM, Pranavan Theivendiram <
>>>> pranavan.11@cse.mrt.ac.lk> wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> I am getting following error when I do $subject.
>>>>>  *ERROR - {EventProcessorDeployer}  Can't deploy the execution plan:
>>>>> CurveFinderOfHealthRequest.xml*
>>>>> *java.lang.AbstractMethodError*
>>>>>
>>>>> What could be the possible reason for this?
>>>>> Thanks
>>>>> *T. Pranavan*
>>>>> *BSc Eng Undergraduate| Department of Computer Science & Engineering
>>>>> ,University of Moratuwa*
>>>>> *Mobile| *0775136836
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> --
>>>> Lahiru Sandaruwan
>>>> Committer and PMC member, Apache Stratos,
>>>> Senior Software Engineer,
>>>> WSO2 Inc., http://wso2.com
>>>> lean.enterprise.middleware
>>>>
>>>> phone: +94773325954
>>>> email: lahirus@wso2.com blog: http://lahiruwrites.blogspot.com/
>>>> linked-in: http://lk.linkedin.com/pub/lahiru-sandaruwan/16/153/146
>>>>
>>>>
>>>
>>> Thanks,
>>> --
>>> *Lasindu Charith*
>>> Software Engineer, WSO2 Inc.
>>> Committer & PMC Member, Apache Stratos
>>> Mobile: +94714427192 | Web: blog.lasindu.com
>>>
>>
>
>
> --
> *Lasindu Charith*
> Software Engineer, WSO2 Inc.
> Committer & PMC Member, Apache Stratos
> Mobile: +94714427192 | Web: blog.lasindu.com
>

Mime
View raw message