stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Swapnil Patil <swapnil.r...@gmail.com>
Subject Re: Log stops at Member initialized when deploying ec2 cartridge
Date Mon, 29 Jun 2015 05:49:39 GMT
Hi Pubudu,

Thanks for the link. I will refer it in future.

I wish I had found and gone through it earlier. Would have saved our time!

Thanks and Regards,
Swapnil

On Mon, Jun 29, 2015 at 4:48 AM, Pubudu Gunatilaka <pubudug@wso2.com> wrote:

> Hi Swapnil,
>
> Glad to hear that. I could find configuration details in [1]. It provides
> all the details for setting up in a EC2 environment.
>
> [1] -
> https://cwiki.apache.org/confluence/display/STRATOS/4.1.0+Install+Stratos+with+EC2+in+a+Testing+Environment
>
> Thank you!
>
> On Mon, Jun 29, 2015 at 2:03 AM, Swapnil Patil <swapnil.rp15@gmail.com>
> wrote:
>
>> Hi Pubudu, Imesh,
>>
>> Thanks for your inputs. Now I can see /tmp/screen.agent.log and it has
>> correct values for mb.
>>
>> I can also see Member started, activated messages in wso2carbon.log.
>>
>> Thanks and Regards,
>> Swapnil
>>
>> On Sun, Jun 28, 2015 at 2:54 PM, Pubudu Gunatilaka <pubudug@wso2.com>
>> wrote:
>>
>>> Hi Swapnil,
>>>
>>> Where is your puppet master running? Is that the same machine where
>>> you run Stratos? You have to change the puppet ip and hostname in
>>> cartridge-config.properties file in <Stratos>/repository/conf
>>> directory. I think puppet-hostname cannot be your puppet hostname.
>>> Check the hostname in puppet master machine and update the above file.
>>>
>>> You don't need to change the message broker port. It should be 1883.
>>>
>>> Basically when we run in distribution mode, we may have to change the
>>> following files in <Stratos>/repository/conf directory.
>>>
>>> 1. cartridge-config.properties - puppet master IP and hostname
>>> 2. jndi.properties - message broker setup
>>> 3. thrift-client-config.xml - CEP setup
>>>
>>> @Mari: Do we have above mentioned file configurations in wiki? I could
>>> not find any. I think we need to add these.
>>>
>>> Thank you!
>>>
>>>
>>> On Sun, Jun 28, 2015 at 7:55 PM, Swapnil Patil <swapnil.rp15@gmail.com>
>>> wrote:
>>> > One more thing as per [1] I set mb_url to tcp://<my-mb-ip>:1883. I
did
>>> not
>>> > change the port from what is mentioned in [1].
>>> >
>>> > Should it be 61616 as per [2]?
>>> >
>>> > I checked netstat for machine on which ActiveMQ is running. I found
>>> LISTEN
>>> > entries for both 1883 and 61616. So thought of keeping it 1883 as per
>>> [1].
>>> >
>>> > [1]
>>> >
>>> https://cwiki.apache.org/confluence/display/STRATOS/4.1.0+Configuring+Puppet+Master
>>> > [2]
>>> >
>>> https://cwiki.apache.org/confluence/display/STRATOS/4.0.0+Configuring+Puppet+Master
>>> >
>>> > Thanks and Regards,
>>> > Swapnil
>>> >
>>> > On Sun, Jun 28, 2015 at 2:12 PM, Swapnil Patil <swapnil.rp15@gmail.com
>>> >
>>> > wrote:
>>> >>
>>> >> Hi Imesh, Pubudu,
>>> >>
>>> >> I configured puppet master again and restarted it. Then I created a
>>> new
>>> >> cartridge with puppet agent pointing to this master. In fact I did it
>>> one by
>>> >> one and tested at each step to find out what was the reason.
>>> >>
>>> >> After deploying application with this new image I still did not find
>>> >> screen.agent.log on spawned instance.
>>> >>
>>> >> While configuring cartridge there was 404 Not Found error for
>>> >> http://169.254.169.254/latest/user-data. Rest of the configuration
>>> ran
>>> >> without errors. Please find attached config.sh.log.
>>> >>
>>> >> I found only 3 logs launch-params, puppet-init.log, puppet_log. I have
>>> >> attached these. Also I have attached puppet.conf of spawned instance.
>>> >>
>>> >> Few observations-
>>> >> 1. In launch-params, PUPPET_IP is set as 127.0.0.1 and
>>> PUPPET_HOSTNAME is
>>> >> set as puppet-hostname. I am not sure if this is correct of these
>>> should be
>>> >> of master.
>>> >>
>>> >> 2. In puppet.conf, server is set as puppet-hostname and not the
>>> hostname
>>> >> of master.
>>> >>
>>> >> Thanks and Regards,
>>> >> Swapnil
>>> >>
>>> >> On Sat, Jun 27, 2015 at 3:57 PM, Swapnil Patil <
>>> swapnil.rp15@gmail.com>
>>> >> wrote:
>>> >>>
>>> >>> Hi Imesh, Pubudu,
>>> >>>
>>> >>> I did not find screen.agent.log under /tmp in ec2 cartridge instance
>>> >>> created. Seems I did something wrong while configuring either puppet
>>> master
>>> >>> or creating cartridge.
>>> >>>
>>> >>> Currently I am verifying the steps for puppet configuration.
>>> >>>
>>> >>> Thanks and Regards,
>>> >>> Swapnil
>>> >>>
>>> >>>
>>> >>>
>>> >>> On Sat, Jun 27, 2015 at 12:39 PM, Imesh Gunaratne <imesh@apache.org>
>>> >>> wrote:
>>> >>>>
>>> >>>> Hi Swapnil,
>>> >>>>
>>> >>>> Can you please verify the CEP IP and MB IP values passed into
the
>>> EC2
>>> >>>> instance created? You could find these values in the cartridge
>>> agent log
>>> >>>> file (/tmp/screen.agent.log).
>>> >>>>
>>> >>>> Thanks
>>> >>>>
>>> >>>> On Sat, Jun 27, 2015 at 12:56 PM, Swapnil Patil <
>>> swapnil.rp15@gmail.com>
>>> >>>> wrote:
>>> >>>>>
>>> >>>>> Thanks Pubudu for the detailed information.
>>> >>>>>
>>> >>>>> I have not disabled mock iaas neither deleted the war file
on my
>>> own. I
>>> >>>>> will check again if the war file is present.
>>> >>>>>
>>> >>>>> I have configured puppet master. I will verify all the steps
again.
>>> >>>>>
>>> >>>>> Thanks and Regards,
>>> >>>>> Swapnil
>>> >>>>>
>>> >>>>> On Jun 27, 2015 12:33 PM, "Pubudu Gunatilaka" <pubudug@wso2.com>
>>> wrote:
>>> >>>>>>
>>> >>>>>> Hi Swapnil,
>>> >>>>>>
>>> >>>>>> You may have already disable the mock iaas when seting
up the ec2
>>> >>>>>> environment [1]. So this could be a reason for that
as well.
>>> Above mentioned
>>> >>>>>> steps are correct for deploying app in mock iaas.
>>> >>>>>>
>>> >>>>>> You can find the cartridge agent log in the spawned
ec2 instance.
>>> >>>>>> Please follow the below steps.
>>> >>>>>>
>>> >>>>>> 1. SSH to spawned ec2 instance.
>>> >>>>>> 2. Go to the /tmp directory.
>>> >>>>>> Here you should be able to find puppet logs as well
as the agent
>>> log.
>>> >>>>>> Check both for any errors. You won't find the agent
log if the
>>> puppet has
>>> >>>>>> not worked well. Check the puppet.conf file in /etc/puppet/
>>> directory in ec2
>>> >>>>>> spawned instance. Hostname and other configurations
should be set
>>> up
>>> >>>>>> accordingly.
>>> >>>>>>
>>> >>>>>> Hope you have already setup your puppet master as well
[2].
>>> >>>>>>
>>> >>>>>> [1] -
>>> >>>>>>
>>> https://cwiki.apache.org/confluence/display/STRATOS/4.1.0+Install+Stratos+with+EC2+in+a+Testing+Environment
>>> >>>>>> [2] -
>>> >>>>>>
>>> https://cwiki.apache.org/confluence/display/STRATOS/4.1.0+Configuring+Puppet+Master
>>> >>>>>>
>>> >>>>>> Thank you!
>>> >>>>>>
>>> >>>>>> On Sat, Jun 27, 2015 at 12:10 PM, Swapnil Patil
>>> >>>>>> <swapnil.rp15@gmail.com> wrote:
>>> >>>>>>>
>>> >>>>>>> Hi Pubudu,
>>> >>>>>>>
>>> >>>>>>> I used different partitions. Because I just ran
deploy.sh in
>>> >>>>>>> samples/applications/simple/single-cartridge-app/scripts/mock.
>>> So this
>>> >>>>>>> script will use network partition defined in
>>> >>>>>>> samples/network-partitions/mock. (Before I ran this
I had
>>> removed earlier
>>> >>>>>>> network partition with undeploy.sh of ec2). Please
correct me if
>>> I am wrong
>>> >>>>>>> here.
>>> >>>>>>>
>>> >>>>>>> Sorry, I am not aware of this log. Could you please
tell me the
>>> name
>>> >>>>>>> of this log and where can I find it?
>>> >>>>>>>
>>> >>>>>>> Thanks and Regards,
>>> >>>>>>> Swapnil
>>> >>>>>>>
>>> >>>>>>> On Sat, Jun 27, 2015 at 6:05 AM, Pubudu Gunatilaka
<
>>> pubudug@wso2.com>
>>> >>>>>>> wrote:
>>> >>>>>>>>
>>> >>>>>>>> Hi Swapnil,
>>> >>>>>>>>
>>> >>>>>>>> Can you attach the cartridge agent log? You
cannot deploy the
>>> same
>>> >>>>>>>> network partition in mock which you used in
ec2. Configurations
>>> are
>>> >>>>>>>> different.
>>> >>>>>>>>
>>> >>>>>>>> Thank you!
>>> >>>>>>>>
>>> >>>>>>>> On Sat, Jun 27, 2015 at 9:47 AM, Swapnil Patil
>>> >>>>>>>> <swapnil.rp15@gmail.com> wrote:
>>> >>>>>>>>>
>>> >>>>>>>>> Hi All,
>>> >>>>>>>>>
>>> >>>>>>>>> I have setup Stratos on one ec2 instance
and MB on another ec2
>>> >>>>>>>>> instance. When I try to deploy ec2 application
using sample
>>> script,
>>> >>>>>>>>> application does get deployed and I can
see ec2 instance being
>>> created for
>>> >>>>>>>>> cartridge.
>>> >>>>>>>>>
>>> >>>>>>>>> But in wso2carbon.log I can only see messages
till Member
>>> >>>>>>>>> initialized. Member started and rest messages
do not appear.
>>> Same happens
>>> >>>>>>>>> with the load balancer extension log.
>>> >>>>>>>>>
>>> >>>>>>>>> I tried deploy application on mock iaas
to see if I get all
>>> >>>>>>>>> messages for that. But I got error invalid
partition while
>>> running deploy
>>> >>>>>>>>> script.
>>> >>>>>>>>>
>>> >>>>>>>>> Please find attached logs. I would appreciate
any help to find
>>> out
>>> >>>>>>>>> the reason behind this and sort this out.
>>> >>>>>>>>>
>>> >>>>>>>>> Thanks and Regards,
>>> >>>>>>>>> Swapnil
>>> >>>>>>>>
>>> >>>>>>>>
>>> >>>>>>>>
>>> >>>>>>>>
>>> >>>>>>>> --
>>> >>>>>>>> Pubudu Gunatilaka
>>> >>>>>>>> Software Engineer
>>> >>>>>>>> WSO2, Inc.: http://wso2.com
>>> >>>>>>>> lean.enterprise.middleware
>>> >>>>>>>> mobile:  +94 77 4078049
>>> >>>>>>>
>>> >>>>>>>
>>> >>>>>>
>>> >>>>>>
>>> >>>>>>
>>> >>>>>> --
>>> >>>>>> Pubudu Gunatilaka
>>> >>>>>> Software Engineer
>>> >>>>>> WSO2, Inc.: http://wso2.com
>>> >>>>>> lean.enterprise.middleware
>>> >>>>>> mobile:  +94 77 4078049
>>> >>>>
>>> >>>>
>>> >>>>
>>> >>>>
>>> >>>> --
>>> >>>> Imesh Gunaratne
>>> >>>>
>>> >>>> Senior Technical Lead, WSO2
>>> >>>> Committer & PMC Member, Apache Stratos
>>> >>>
>>> >>>
>>> >>
>>> >
>>>
>>>
>>>
>>> --
>>> Pubudu Gunatilaka
>>> Software Engineer
>>> WSO2, Inc.: http://wso2.com
>>> lean.enterprise.middleware
>>> mobile:  +94 77 4078049
>>>
>>
>>
>
>
> --
>
> *Pubudu Gunatilaka*
> Software Engineer
> WSO2, Inc.: http://wso2.com
> lean.enterprise.middleware
> mobile:  +94 77 4078049
>

Mime
View raw message