stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Swapnil Patil <swapnil.r...@gmail.com>
Subject Re: Stratos installation successful but console not showing up
Date Tue, 16 Jun 2015 06:51:12 GMT
Thanks Lasindu for the feedback. I will try that.

Regards,
Swapnil

On Tue, Jun 16, 2015 at 6:47 AM, Lasindu Charith <lasindu@wso2.com> wrote:

> Hi Swapnil,
>
> Yes, first get an update from the latest Git master and try again.
> If not try the rc-2 tag(
> https://github.com/apache/stratos/releases/tag/4.1.0-rc2) to build.
>
> Thanks,
>
> On Tue, Jun 16, 2015 at 12:13 PM, Swapnil Patil <swapnil.rp15@gmail.com>
> wrote:
>
>> Just an update.
>>
>> Running stratos.sh from apache-stratos-4.1.0-SNAPSHOT.zip (which I built
>> locally) gives above partial output. So server does not start.
>>
>> But running stratos.sh from apache-stratos-4.0.0.zip (which I downloaded)
>> does start the server.
>>
>> Do you think I should build it again on latest code?
>>
>> Thanks and Regards,
>> Swapnil
>>
>> On Tue, Jun 16, 2015 at 6:22 AM, Swapnil Patil <swapnil.rp15@gmail.com>
>> wrote:
>>
>>> Hi Reka,
>>>
>>> Thanks for the sample log.
>>>
>>> This is all I got. The command is still running and nothing is added to
>>> the log.
>>>
>>> Thanks and Regards,
>>> Swapnil
>>>
>>> On Tue, Jun 16, 2015 at 5:36 AM, Reka Thirunavukkarasu <reka@wso2.com>
>>> wrote:
>>>
>>>> Hi Swapnil,
>>>>
>>>> You have attached the partial logs only. Do you have the complete
>>>> stratos startup logs? I have attached a sample startup log here with. If
>>>> the stratos started successfully, then you can see the console in
>>>> https://localhost:9443/console/
>>>>
>>>>
>>>>
>>>> On Tue, Jun 16, 2015 at 10:31 AM, Swapnil Patil <swapnil.rp15@gmail.com
>>>> > wrote:
>>>>
>>>>> I followed steps below.
>>>>>
>>>>> 1. cleaned the earlier setup. So now I don't have userstore database.
>>>>> 2. Started activemq
>>>>> 3. Extratcted apache-stratos-4.1.0-SNAPSHOT.zip to a new folder.
>>>>> 4. Executed the command -  sh stratos.sh. I got the output attached
>>>>> and it is still running.
>>>>>
>>>>> How do I check if server started successfully? Should I be able to see
>>>>> console now? or am I missing anything?
>>>>>
>>>>> Thanks and Regards,
>>>>> Swapnil
>>>>>
>>>>>
>>>>> On Mon, Jun 15, 2015 at 6:47 PM, Imesh Gunaratne <imesh@apache.org>
>>>>> wrote:
>>>>>
>>>>>> May be you are experiencing a permission issue. Try to extract the
>>>>>> Stratos zip file again with your local user into a new folder and
run the
>>>>>> stratos.sh.
>>>>>>
>>>>>> On Tue, Jun 16, 2015 at 12:08 AM, Swapnil Patil <
>>>>>> swapnil.rp15@gmail.com> wrote:
>>>>>>
>>>>>>> As an experiment, I replaced apache-stratos-*4.1.0*-SNAPSHOT.zip
>>>>>>> with apache-stratos-*4.0.0*.zip and made necessary changes in
>>>>>>> setup.conf file. With this server was up and I could see console.
>>>>>>>
>>>>>>> I thought of trying this because earlier I had tried it and server
>>>>>>> had started. But as GSoC students should work on master branch.
I built the
>>>>>>> master code and used the apache-stratos-*4.1.0*-SNAPSHOT.zip.
And
>>>>>>> then server didn't start up.
>>>>>>>
>>>>>>> So I think there could be something wrong with the zip that got
>>>>>>> built. The code that I built was few days older. Should I try
getting the
>>>>>>> latest and try building and using the latest zip?
>>>>>>>
>>>>>>> Thanks and Regards,
>>>>>>> Swapnil
>>>>>>>
>>>>>>> On Mon, Jun 15, 2015 at 6:29 PM, Swapnil Patil <
>>>>>>> swapnil.rp15@gmail.com> wrote:
>>>>>>>
>>>>>>>> I tried following commands and got respective output.
>>>>>>>>
>>>>>>>> 1. sh stratos.sh - got permission denied error in stack trace.
>>>>>>>> Please refer attached log.
>>>>>>>>
>>>>>>>> 2. sh stratos.sh start - ps: write error: Bad file descriptor
>>>>>>>>
>>>>>>>> 3. sudo sh stratos.sh - Output as per wso2carbon.log attached
>>>>>>>> earlier. And didn't exit.
>>>>>>>>
>>>>>>>> 4. sudo sh stratos.sh start - ps: write error: Bad file descriptor
>>>>>>>>
>>>>>>>> Thanks and Regards,
>>>>>>>> Swapnil
>>>>>>>>
>>>>>>>> On Mon, Jun 15, 2015 at 6:02 PM, Imesh Gunaratne <imesh@apache.org>
>>>>>>>> wrote:
>>>>>>>>
>>>>>>>>> You could use following:
>>>>>>>>> sh stratos.sh
>>>>>>>>> sh stratos.sh start
>>>>>>>>>
>>>>>>>>> On Mon, Jun 15, 2015 at 11:25 PM, Swapnil Patil <
>>>>>>>>> swapnil.rp15@gmail.com> wrote:
>>>>>>>>>
>>>>>>>>>> Hi Imesh, Lasindu,
>>>>>>>>>>
>>>>>>>>>> I did try it without sudo. But still the error "ps:
write error:
>>>>>>>>>> Bad file descriptor" persists.
>>>>>>>>>>
>>>>>>>>>> Just to confirm - I need to run "./stratos.sh -Dprofile=default
>>>>>>>>>> start" to start the server. Am I right?
>>>>>>>>>>
>>>>>>>>>> Thanks and Regards,
>>>>>>>>>> Swapnil
>>>>>>>>>>
>>>>>>>>>> On Mon, Jun 15, 2015 at 5:44 PM, Imesh Gunaratne
<
>>>>>>>>>> imesh@apache.org> wrote:
>>>>>>>>>>
>>>>>>>>>>> Hi Swapnil,
>>>>>>>>>>>
>>>>>>>>>>> According to the carbon log the server has not
started. Please
>>>>>>>>>>> try to start the server manually with your local
user as Lasindu has
>>>>>>>>>>> mentioned (without the installer).
>>>>>>>>>>>
>>>>>>>>>>> Thanks
>>>>>>>>>>>
>>>>>>>>>>> On Mon, Jun 15, 2015 at 11:08 PM, Swapnil Patil
<
>>>>>>>>>>> swapnil.rp15@gmail.com> wrote:
>>>>>>>>>>>
>>>>>>>>>>>> Hi Lasindu,
>>>>>>>>>>>>
>>>>>>>>>>>> No, I did not. I will try that. Thanks!
>>>>>>>>>>>>
>>>>>>>>>>>> Regards,
>>>>>>>>>>>> Swapnil
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> On Mon, Jun 15, 2015 at 4:42 PM, Lasindu
Charith <
>>>>>>>>>>>> lasindu@wso2.com> wrote:
>>>>>>>>>>>>
>>>>>>>>>>>>> Hi Swapnali,
>>>>>>>>>>>>>
>>>>>>>>>>>>> Did you try starting the server without
'sudo'(super user)?
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> On Mon, Jun 15, 2015 at 9:57 PM, Swapnil
Patil <
>>>>>>>>>>>>> swapnil.rp15@gmail.com> wrote:
>>>>>>>>>>>>>
>>>>>>>>>>>>>> I ran start-server.sh -p "default".
But still the issue
>>>>>>>>>>>>>> persists.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Output of start-server.sh is as follows.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> $ sudo ./start-servers.sh -p "default"
>>>>>>>>>>>>>> source it
>>>>>>>>>>>>>> 'default' profile selected.
>>>>>>>>>>>>>> INFO: Using default configuration
>>>>>>>>>>>>>> (you can configure options in one
of these file:
>>>>>>>>>>>>>> /etc/default/activemq /root/.activemqrc)
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> INFO: Invoke the following command
to create a configuration
>>>>>>>>>>>>>> file
>>>>>>>>>>>>>> /usr/local/stratos_installation/stratos/apache-activemq-5.9.1/bin/activemq
>>>>>>>>>>>>>> setup [ /etc/default/activemq | /root/.activemqrc
]
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> INFO: Using java '/usr/local/jdk1.7.0_79/jre/bin/java'
>>>>>>>>>>>>>> INFO: Process with pid '10296' is
already running
>>>>>>>>>>>>>> /usr/local/stratos_installation/stratos/apache-stratos-default/bin/stratos.sh
>>>>>>>>>>>>>> -Dprofile=default start
>>>>>>>>>>>>>> *ps: write error: Bad file descriptor*
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> I am suspicious about this last line.
I ran stratos.sh
>>>>>>>>>>>>>> -Dprofile=default start manually
again. It also threw same error.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Any suggestion to resolve this error?
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Thanks and Regards,
>>>>>>>>>>>>>> Swapnil
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> On Mon, Jun 15, 2015 at 10:55 AM,
Swapnil Patil <
>>>>>>>>>>>>>> swapnil.rp15@gmail.com> wrote:
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Hi Udara,
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Ok. I will try that.
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Thanks,
>>>>>>>>>>>>>>> Swapnil
>>>>>>>>>>>>>>> On Jun 15, 2015 4:19 PM, "Udara
Liyanage" <udara@wso2.com>
>>>>>>>>>>>>>>> wrote:
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> Hi Swapnil,
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> It seems you are running
low on RAM. However could you try
>>>>>>>>>>>>>>>> just starting Stratos without
the installer.
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> *TID: [0] [STRATOS] [2015-06-15
10:02:07,072]  WARN
>>>>>>>>>>>>>>>> {org.wso2.carbon.core.bootup.validator.util.ValidationResultPrinter}
-
>>>>>>>>>>>>>>>>  Swap Memory size (MB): 1905
of the system is below the recommended minimum
>>>>>>>>>>>>>>>> size :2048*
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> On Mon, Jun 15, 2015 at 4:00
PM, Swapnil Patil <
>>>>>>>>>>>>>>>> swapnil.rp15@gmail.com>
wrote:
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> Hi All,
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> I have built Stratos
locally and using it while
>>>>>>>>>>>>>>>>> installation (apache-stratos-4.1.0-SNAPSHOT.zip
and other zips like
>>>>>>>>>>>>>>>>> cartridge agent and load
balancer). Installation is successful but Stratos
>>>>>>>>>>>>>>>>> console is not showing
up.
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> I waited for half an
hour. Output of netstat doesn't show
>>>>>>>>>>>>>>>>> any entry for port 9443.
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> Please find attached
logs.
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> I would appreciate any
help on this.
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> Thank and Regards,
>>>>>>>>>>>>>>>>> Swapnil
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> --
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> Udara Liyanage
>>>>>>>>>>>>>>>> Software Engineer
>>>>>>>>>>>>>>>> WSO2, Inc.: http://wso2.com
>>>>>>>>>>>>>>>> lean. enterprise. middleware
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> web: http://udaraliyanage.wordpress.com
>>>>>>>>>>>>>>>> phone: +94 71 443 6897
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> --
>>>>>>>>>>>>> *Lasindu Charith*
>>>>>>>>>>>>> Software Engineer, WSO2 Inc.
>>>>>>>>>>>>> Mobile: +94714427192
>>>>>>>>>>>>> Web: blog.lasindu.com
>>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> --
>>>>>>>>>>> Imesh Gunaratne
>>>>>>>>>>>
>>>>>>>>>>> Senior Technical Lead, WSO2
>>>>>>>>>>> Committer & PMC Member, Apache Stratos
>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> --
>>>>>>>>> Imesh Gunaratne
>>>>>>>>>
>>>>>>>>> Senior Technical Lead, WSO2
>>>>>>>>> Committer & PMC Member, Apache Stratos
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Imesh Gunaratne
>>>>>>
>>>>>> Senior Technical Lead, WSO2
>>>>>> Committer & PMC Member, Apache Stratos
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> Reka Thirunavukkarasu
>>>> Senior Software Engineer,
>>>> WSO2, Inc.:http://wso2.com,
>>>> Mobile: +94776442007
>>>>
>>>>
>>>>
>>>
>>
>
>
> --
> *Lasindu Charith*
> Software Engineer, WSO2 Inc.
> Committer & PMC Member, Apache Stratos
> Mobile: +94714427192 | Web: blog.lasindu.com
>

Mime
View raw message