stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Swapnil Patil <swapnil.r...@gmail.com>
Subject Re: httpclient-4.1.1-wso2v1.jar and httpclient-4.2.jar
Date Sat, 20 Jun 2015 17:10:16 GMT
Thanks Gayan.

Adding a new dependency for httpclient-4.2.5.wso2v1.jar resolved the
problem.

Regards,
Swapnil

On Fri, Jun 19, 2015 at 3:28 PM, Swapnil Patil <swapnil.rp15@gmail.com>
wrote:

> Thanks Gayan.
>
> I will look into it.
>
> Thanks and Regards,
> Swapnil
>
> On Fri, Jun 19, 2015 at 11:41 AM, Gayan Gunarathne <gayang@wso2.com>
> wrote:
>
>>
>> I guess we already using the latest of the httpclient jar
>> library(httpclient-4.2.5.wso2v1.jar) with some of Stratos component. eg:
>> mock-iaas client[1]
>> You can use the same way.
>> [1]
>> https://github.com/apache/stratos/blob/master/components/org.apache.stratos.mock.iaas.client/pom.xml
>>
>> Thanks,
>> Gayan
>>
>>
>> On Thu, Jun 18, 2015 at 11:12 PM, Swapnil Patil <swapnil.rp15@gmail.com>
>> wrote:
>>
>>> Thanks Gayan.
>>>
>>> I think I need to replace the current version
>>> with httpclient-4.2.3.wso2v1.jar. If yes, could you please let me know the
>>> place where should I make the change. Because I am not sure which
>>> dependency needs httpclient-4.1.1-wso2v1.jar. So I am not sure how
>>> should I use this newer version instead of older.
>>>
>>> Please find attached pom.xml for this project.
>>>
>>> Thanks and Regards,
>>> Swapnil
>>>
>>> On Thu, Jun 18, 2015 at 5:05 PM, Gayan Gunarathne <gayang@wso2.com>
>>> wrote:
>>>
>>>> Yeah. DefaultClientConnectionOperator is introduced after the 4.2
>>>> version[1].
>>>>
>>>> I think you can use the latest lib[2].
>>>>
>>>> [1]
>>>> http://hc.apache.org/httpcomponents-client-ga/httpclient/apidocs/org/apache/http/impl/conn/DefaultClientConnectionOperator.html
>>>> [2]
>>>> http://maven.wso2.org/nexus/content/groups/wso2-public/org/apache/httpcomponents/wso2/httpclient/4.2.3.wso2v1/
>>>>
>>>> Thanks,
>>>> Gayan
>>>>
>>>> On Thu, Jun 18, 2015 at 10:01 PM, Swapnil Patil <swapnil.rp15@gmail.com
>>>> > wrote:
>>>>
>>>>> Hi All,
>>>>>
>>>>> I am trying to run AWS load balancer extension which is currently
>>>>> under development. While creating AWS client I am getting exception
>>>>> "java.lang.NoSuchMethodError:
>>>>> org.apache.http.impl.conn.DefaultClientConnectionOperator.<init>(Lorg/apache/http/conn/scheme/SchemeRegistry;Lorg/apache/http/conn/DnsResolver;)V"
>>>>>
>>>>> This can be resolved if httpclient-4.2.jar is referenced instead of
>>>>> httpclient-4.1.1-wso2v1.jar. Now the problem is in the lib folder of
>>>>> extension (which is set as classpath) there are two different
>>>>> jars httpclient-4.1.1-wso2v1.jar and httpclient-4.2.jar with different
>>>>> versions. It seems first reference is made to httpclient-4.1.1-wso2v1.jar
>>>>> which is why the exception. If I remove httpclient-4.1.1-wso2v1.jar from
>>>>> classpath, the error gets resolved.
>>>>>
>>>>> So just wondering by which dependency httpclient-4.1.1-wso2v1.jar gets
>>>>> added into lib folder? Do we have something like httpclient-4.2-wso2v1.jar
>>>>> which will have classes corresponding to httpclient-4.2.jar, which can
be
>>>>> used? Or if there is any other solution to this?
>>>>>
>>>>> Thanks and Regards,
>>>>> Swapnil
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> Gayan Gunarathne
>>>> Technical Lead, WSO2 Inc. (http://wso2.com)
>>>> Committer & PMC Member, Apache Stratos
>>>> email : gayang@wso2.com  | mobile : +94 766819985
>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>> --
>>
>> Gayan Gunarathne
>> Technical Lead, WSO2 Inc. (http://wso2.com)
>> Committer & PMC Member, Apache Stratos
>> email : gayang@wso2.com  | mobile : +94 766819985
>>
>>
>>
>
>

Mime
View raw message